summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm27
1 files changed, 23 insertions, 4 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 188e91d1e1..509d428f64 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
@@ -26,6 +26,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
+ #:use-module (gnu packages)
#:use-module (gnu packages perl)
#:use-module (gnu packages base))
@@ -40,7 +41,8 @@
version ".tar.gz"))
(sha256
(base32
- "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))))
+ "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
+ (patches (search-patches "aspell-default-dict-dir.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -53,6 +55,15 @@
'("ASPELL_CONF" "" =
("${ASPELL_CONF:-\"dict-dir ${GUIX_PROFILE:-$HOME/.guix-profile}/lib/aspell\"}")))))))))
(inputs `(("perl" ,perl)))
+
+ (native-search-paths
+ ;; This is a Guix-specific environment variable that takes a single
+ ;; entry, not an actual search path.
+ (list (search-path-specification
+ (variable "ASPELL_DICT_DIR")
+ (separator #f)
+ (files '("lib/aspell")))))
+
(home-page "http://aspell.net/")
(synopsis "Spell checker")
(description
@@ -62,12 +73,12 @@ documents written in the UTF-8 encoding and its ability to use multiple
dictionaries, including personal ones.")
(license lgpl2.1+)))
-
;;;
;;; Dictionaries.
;;;
;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use
-;;; them.
+;;; them, or set the Guix-specific 'ASPELL_DICT_DIR', or just do nothing (as
+;;; long as 'HOME' is set, that's fine!).
;;;
(define* (aspell-dictionary dict-name full-name
@@ -190,3 +201,11 @@ dictionaries, including personal ones.")
#:sha256
(base32
"1zxr8958v37v260fkqd4pg37ns5h5kyqm54hn1hg70wq5cz8h512")))
+
+(define-public aspell-dict-pt-br
+ (aspell-dictionary "pt-br" "Brazilian Portuguese"
+ #:version "20090702-0"
+ #:prefix "aspell6-"
+ #:sha256
+ (base32
+ "1y09lx9zf2rnp55r16b2vgj953l3538z1vaqgflg9mdvm555bz3p")))