summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm51
1 files changed, 28 insertions, 23 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 8682ecd8d0..34fb9ee4fd 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -226,7 +227,7 @@ the real span of the lattice.")
(define-public pari-gp
(package
(name "pari-gp")
- (version "2.11.2")
+ (version "2.11.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -234,7 +235,7 @@ the real span of the lattice.")
version ".tar.gz"))
(sha256
(base32
- "0fck8ssmirl8fy7s4mspgrxjs5sag76xbshqlqzkcl3kqyrk4raa"))))
+ "070bjw4kg7r6lqs1hfs08n5fmjv90cpwflp3wr04hbrmyz28zj5z"))))
(build-system gnu-build-system)
(native-inputs
`(("texlive" ,(texlive-union
@@ -268,7 +269,7 @@ PARI is also available as a C library to allow for faster computations.")
(define-public gp2c
(package
(name "gp2c")
- (version "0.0.11pl2")
+ (version "0.0.11pl3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -276,7 +277,7 @@ PARI is also available as a C library to allow for faster computations.")
version ".tar.gz"))
(sha256
(base32
- "0wqsf05wgkqvmmsx7jinvzdqav6rl56sr8haibgs31nzz4x9xz9g"))))
+ "0yymbrgyjw500hqgmkj5m4nmscd7c9rs9w2c96lxgrcyab8krhrm"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)))
(inputs `(("pari-gp" ,pari-gp)))
@@ -432,9 +433,6 @@ maple, mupad and the TI89. It is available as a standalone program (graphic
or text interfaces) or as a C++ library.")
(license license:gpl3+)))
-(define-public giac-xcas
- (deprecated-package "giac-xcas" giac))
-
(define-public flint
(package
(name "flint")
@@ -561,42 +559,50 @@ these types and other mathematical functions.")
(define-public ntl
(package
(name "ntl")
- (version "9.7.0")
+ (version "11.4.3")
(source (origin
(method url-fetch)
- (uri (string-append "http://shoup.net/ntl/ntl-"
+ (uri (string-append "https://shoup.net/ntl/ntl-"
version ".tar.gz"))
- (sha256 (base32
- "115frp5flyvw9wghz4zph1b3llmr5nbxk1skgsggckr81fh3gmxq"))))
+ (sha256
+ (base32
+ "1lisp3064rch3jaa2wrhy1s9kll7i3ka3d0y6lj6l3l4ckfcrhdp"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "src/libtool-origin")
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("libtool" ,libtool)
("perl" ,perl))) ; for configuration
- ;; FIXME: Add optional input gf2x once available; then also add
- ;; configure flag "NTL_GF2X_LIB=on".
(inputs
- `(("gmp" ,gmp)))
+ `(("gmp" ,gmp)
+ ("gf2x" ,gf2x)))
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(chdir "src")
- (system* "./configure"
+ (invoke "./configure"
(string-append "PREFIX=" (assoc-ref outputs "out"))
+ (string-append "LIBTOOL=" (assoc-ref inputs "libtool") "/bin/libtool")
+ ;; set the library prefixes explicitly so that they get
+ ;; embedded in the .la file
+ (string-append "GMP_PREFIX=" (assoc-ref inputs "gmp"))
+ (string-append "GF2X_PREFIX=" (assoc-ref inputs "gf2x"))
;; Do not build especially for the build machine.
"NATIVE=off"
- ;; Also do not tune to the build machine.
- "WIZARD=off"
- "SHARED=on")
- #t)))))
+ "NTL_GF2X_LIB=on"
+ "SHARED=on"))))))
(synopsis "C++ library for number theory")
(description
"NTL is a C++ library providing data structures and algorithms
for manipulating signed, arbitrary length integers, and for vectors,
matrices, and polynomials over the integers and over finite fields.")
(license license:gpl2+)
- (home-page "http://shoup.net/ntl/")))
+ (home-page "https://shoup.net/ntl/")))
(define-public singular
(package
@@ -1454,8 +1460,7 @@ of M4RI from F_2 to F_{2^e}.")
("automake" ,automake)
("libtool" ,libtool)))
(inputs
- `(("gmp" ,gmp)
- ("ntl" ,ntl)
+ `(("ntl" ,ntl)
("pari-gp" ,pari-gp)))
(synopsis "Ranks of elliptic curves and modular symbols")
(description "The eclib package includes mwrank (for 2-descent on