summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index fb3b3e94b3..41464ca882 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -413,19 +413,18 @@ cosine/ sine transforms or DCT/DST).")
;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
#:test-target "check"
- #:phases (alist-cons-before
- 'check 'build-tests
- (lambda _
- ;; First build the tests, in parallel.
- ;; See <http://eigen.tuxfamily.org/index.php?title=Tests>.
- (let* ((cores (parallel-job-count))
- (dash-j (format #f "-j~a" cores)))
- ;; These variables are supposed to be honored.
- (setenv "EIGEN_MAKE_ARGS" dash-j)
- (setenv "EIGEN_CTEST_ARGS" dash-j)
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'build-tests
+ (lambda _
+ ;; First build the tests, in parallel.
+ ;; See <http://eigen.tuxfamily.org/index.php?title=Tests>.
+ (let* ((cores (parallel-job-count))
+ (dash-j (format #f "-j~a" cores)))
+ ;; These variables are supposed to be honored.
+ (setenv "EIGEN_MAKE_ARGS" dash-j)
+ (setenv "EIGEN_CTEST_ARGS" dash-j)
- (zero? (system* "make" "buildtests" dash-j))))
- %standard-phases)))
+ (zero? (system* "make" "buildtests" dash-j))))))))
(home-page "http://eigen.tuxfamily.org")
(synopsis "C++ template library for linear algebra")
(description