summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 4fb15c6471..83f03a074a 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -505,6 +505,30 @@ syntax is similar to that of C, so basic usage is familiar. It also includes
\"dc\", a reverse-polish calculator.")
(license license:gpl2+)))
+;; The original kiss-fft does not have a complete build system and does not
+;; build any shared libraries. This is a fork used by Extempore.
+(define-public kiss-fft-for-extempore
+ (package
+ (name "kiss-fft-for-extempore")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/extemporelang/kiss_fft/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hkp9l6l4c92fb1l2sh6a6zv1hynpvb2s4d03vd8vxyvybc0l4pv"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests included
+ (home-page "https://github.com/extemporelang/kiss_fft")
+ (synopsis "Mixed-radix Fast Fourier Transform")
+ (description
+ "Kiss FFT attempts to be a reasonably efficient, moderately useful FFT
+that can use fixed or floating data types and can easily be incorporated into
+a C program.")
+ (license license:bsd-3)))
+
(define-public fftw
(package
(name "fftw")