summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 76f385e340..4288913f78 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -576,6 +576,22 @@ cosine/ sine transforms or DCT/DST).")
(string-append (package-description fftw)
" Single-precision version."))))
+;; FIXME: These packages are used temporarily by packages like Ardour until
+;; "--enable-flags" is added to the fftw and fftwf packages.
+(define-public fftw-with-threads
+ (package (inherit fftw)
+ (arguments
+ (substitute-keyword-arguments (package-arguments fftw)
+ ((#:configure-flags flags)
+ `(cons "--enable-threads" ,flags))))))
+
+(define-public fftwf-with-threads
+ (package (inherit fftwf)
+ (arguments
+ (substitute-keyword-arguments (package-arguments fftwf)
+ ((#:configure-flags flags)
+ `(cons "--enable-threads" ,flags))))))
+
(define-public fftw-openmpi
(package (inherit fftw)
(name "fftw-openmpi")