summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm400
1 files changed, 162 insertions, 238 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index afb3afac75..4ed1f1abf3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -180,13 +180,9 @@
"supath=/run/setuid-programs/su"))
#t)))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(inputs
- `(("glib" ,glib)
- ("gtk+" ,gtk+-2)))
+ (list glib gtk+-2))
(synopsis "Graphical front end for @command{su}")
(description
"Ktsuss stands for ``Keep the @command{su} simple, stupid''.
@@ -208,8 +204,7 @@ simplicity in mind.")
(base32 "15xp47sz7kk1ciffw3f5xw2jg2mb2lqrbr3q6p4bkbz5dap9iy8p"))))
(build-system gnu-build-system)
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)))
+ (list bison flex))
(inputs
`(("libgcrypt" ,libgcrypt)
("libgpg-error" ,libgpg-error)
@@ -244,10 +239,9 @@ usual file attributes can be checked for inconsistencies.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("which" ,which)))
+ (list pkg-config which))
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(arguments
`(#:tests? #f ; no test suite
#:make-flags
@@ -292,17 +286,15 @@ and provides a \"top-like\" mode (monitoring).")
'(#:configure-flags '("--localstatedir=/var")
#:make-flags '("GUILE_AUTO_COMPILE=0")))
(native-inputs
- `(("pkg-config" ,pkg-config)
-
- ;; This is the Guile we use as a cross-compiler...
- ("guile" ,guile-3.0)))
+ (list pkg-config
+ ;; This is the Guile we use as a cross-compiler...
+ guile-3.0))
(inputs
;; ... and this is the one that appears in shebangs when cross-compiling.
- `(("guile" ,guile-3.0)
-
- ;; The 'shepherd' command uses Readline when used interactively. It's
- ;; an unusual use case though, so we don't propagate it.
- ("guile-readline" ,guile-readline)))
+ (list guile-3.0
+ ;; The 'shepherd' command uses Readline when used interactively. It's
+ ;; an unusual use case though, so we don't propagate it.
+ guile-readline))
(synopsis "System service manager")
(description
"The GNU Shepherd is a daemon-managing daemon, meaning that it supervises
@@ -317,22 +309,18 @@ interface and is based on GNU Guile.")
(inherit shepherd)
(name "guile2.2-shepherd")
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("guile" ,guile-2.2)))
+ (list pkg-config guile-2.2))
(inputs
- `(("guile" ,guile-2.2)
- ("guile2.2-readline" ,guile2.2-readline)))))
+ (list guile-2.2 guile2.2-readline))))
(define-public guile2.0-shepherd
(package
(inherit shepherd)
(name "guile2.0-shepherd")
(native-inputs
- `(("help2man" ,help2man)
- ("pkg-config" ,pkg-config)
- ("guile" ,guile-2.0)))
+ (list help2man pkg-config guile-2.0))
(inputs
- `(("guile" ,guile-2.0)))
+ (list guile-2.0))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -409,8 +397,7 @@ inspired by @command{vi}.")
,(dirname (which "readlink"))))))
#t)))))
(inputs
- `(("python" ,python)
- ("util-linux" ,util-linux))) ; contains sfdisk for growpart
+ (list python util-linux)) ; contains sfdisk for growpart
(home-page "https://launchpad.net/cloud-utils")
(synopsis "Set of utilities for cloud computing environments")
(description
@@ -656,7 +643,7 @@ console.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -704,7 +691,7 @@ memory, disks, network and processes.")
(base32 "1fwmiwvs8ax9az3hbp1p79x6m3wq73pn3vkbhcg9jvps4wv8wcwb"))))
(build-system python-build-system)
(inputs
- `(("python-psutil" ,python-psutil)))
+ (list python-psutil))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -931,7 +918,7 @@ login, passwd, su, groupadd, and useradd.")
(mkdir-p man8))
#t)))
#:tests? #f)) ; no tests
- (inputs `(("shadow" ,shadow)))
+ (inputs (list shadow))
(home-page "https://sourceforge.net/projects/mingetty")
(synopsis "Getty for the text console")
@@ -980,8 +967,7 @@ to allow automatic login and starting any app.")
(map (cut string-append etc "/" <>)
'("services" "protocols" "rpc")))
#t))))
- (native-inputs `(("tar" ,tar)
- ("xz" ,xz)))
+ (native-inputs (list tar xz))
(synopsis "IANA protocol, port, and RPC number assignments")
(description
"This package provides the /etc/services, /etc/protocols, and /etc/rpc
@@ -1056,9 +1042,8 @@ would need and has several interesting built-in capabilities.")
(install-file "nc.1" man)
(install-file "debian/copyright" doc)
(copy-recursively "debian/examples" examples)))))))
- (inputs `(("libbsd" ,libbsd)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("quilt" ,quilt)))
+ (inputs (list libbsd))
+ (native-inputs (list pkg-config quilt))
(home-page "https://packages.debian.org/sid/netcat-openbsd")
(synopsis "Read and write data over TCP/IP")
(description
@@ -1140,7 +1125,7 @@ recursive runs on the generated subnets. (also IPv6)
(let ((out (assoc-ref outputs "out")))
(install-file "prips"
(string-append out "/bin"))))))))
- (native-inputs `(("perl-test-harness" ,perl-test-harness)))
+ (native-inputs (list perl-test-harness))
(synopsis "Tool that prints the IP addresses in a given range")
(description "Prips can be used to print all of the IP addresses in
a given range. This allows the enhancement of tools only work
@@ -1161,8 +1146,7 @@ recursive runs on the generated subnets. (also IPv6)
"053hfp7s66lnilm1ii4jrjmy44wpa2cwwh6f0sl8cyz0mm813x4b"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("alive_cv_nice_ping=yes")))
- (inputs `(("guile" ,guile-2.0)
- ("inetutils" ,inetutils)))
+ (inputs (list guile-2.0 inetutils))
(home-page "https://www.gnu.org/software/alive/")
(synopsis "Autologin and keep-alive daemon")
(description
@@ -1309,8 +1293,7 @@ connection alive.")
#t))))))
(native-inputs
- `(("perl" ,perl)
- ("file" ,file)))
+ (list perl file))
(inputs `(("inetutils" ,inetutils)
;; TODO(core-updates): simply make this unconditional
@@ -1361,12 +1344,12 @@ tools: server, client, and relay agent.")
(base32 "1df827m3vkjq2bcs5y9wg2cygvpdwl8ppl446qqhyym584gz54nl"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("bison" ,bison)
- ("check" ,check)
- ("flex" ,flex)
- ("pkg-config" ,pkg-config)))
+ (list autoconf
+ automake
+ bison
+ check
+ flex
+ pkg-config))
(arguments
`(#:configure-flags '("--with-check")))
(home-page "https://radvd.litech.org/")
@@ -1391,8 +1374,7 @@ message. These messages are required for IPv6 stateless autoconfiguration.")
"1m5x26vlbymp90k1qh0w3nj2nxzyvfrmfmwpj17k81dgri55ya7d"))))
(build-system gnu-build-system)
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)))
+ (list bison flex))
(arguments
;; There are some tests in testprogs/, but no automated test suite.
`(#:tests? #f
@@ -1426,9 +1408,8 @@ network statistics collection, security monitoring, network debugging, etc.")
(base32
"1ghfs5gifzrk3813zf9zalfbjs70wg6llz6q31k180r7zf2nkcvr"))))
(build-system gnu-build-system)
- (inputs `(("libpcap" ,libpcap)
- ("openssl" ,openssl)))
- (native-inputs `(("perl" ,perl))) ; for tests
+ (inputs (list libpcap openssl))
+ (native-inputs (list perl)) ; for tests
(home-page "https://www.tcpdump.org/")
(synopsis "Network packet analyzer")
(description
@@ -1451,11 +1432,9 @@ through the network interface controller.")
"1855np7c4b0bqzhf1l1dyzxb90fpnvrirdisajhci5am6als31z9"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("glib" ,glib)
- ("ncurses" ,ncurses)
- ("libpcap" ,libpcap)))
+ (list glib ncurses libpcap))
(home-page
"https://web.archive.org/web/20160703195221/http://jnettop.kubs.info/wiki/")
(synopsis "Visualize network traffic by bandwidth use")
@@ -1524,26 +1503,26 @@ by bandwidth they use.")
(find-files "." ".*")))
#t))))))
(native-inputs
- `(("perl-cpan-changes" ,perl-cpan-changes)
- ("perl-file-slurp" ,perl-file-slurp)
- ("perl-file-which" ,perl-file-which)
- ("perl-module-build" ,perl-module-build)
- ("perl-readonly" ,perl-readonly)
- ("perl-test-differences" ,perl-test-differences)
- ("perl-test-distmanifest" ,perl-test-distmanifest)
- ("perl-test-perltidy" ,perl-test-perltidy)
- ("perl-test-pod" ,perl-test-pod)
- ("perl-test-pod-coverage" ,perl-test-pod-coverage)
- ("perl-test-trap" ,perl-test-trap)
- ("perltidy" ,perltidy)))
+ (list perl-cpan-changes
+ perl-file-slurp
+ perl-file-which
+ perl-module-build
+ perl-readonly
+ perl-test-differences
+ perl-test-distmanifest
+ perl-test-perltidy
+ perl-test-pod
+ perl-test-pod-coverage
+ perl-test-trap
+ perltidy))
(inputs
- `(("perl-exception-class" ,perl-exception-class)
- ("perl-sort-naturally" ,perl-sort-naturally)
- ("perl-tk" ,perl-tk)
- ("perl-try-tiny" ,perl-try-tiny)
- ("perl-x11-protocol" ,perl-x11-protocol)
- ("perl-x11-protocol-other" ,perl-x11-protocol-other)
- ("xterm" ,xterm)))
+ (list perl-exception-class
+ perl-sort-naturally
+ perl-tk
+ perl-try-tiny
+ perl-x11-protocol
+ perl-x11-protocol-other
+ xterm))
;; The clusterssh.sourceforge.net address requires login to view
(home-page "https://sourceforge.net/projects/clusterssh/")
(synopsis "Secure concurrent multi-server terminal control")
@@ -1589,10 +1568,7 @@ over ssh connections.")
("pkg-config" ,pkg-config)
("python" ,python)))
(inputs
- `(("glib" ,glib)
- ("mit-krb5" ,mit-krb5)
- ("openldap" ,openldap)
- ("polkit" ,polkit)))
+ (list glib mit-krb5 openldap polkit))
(synopsis "DBus service for network authentication")
(description "This package provides an on demand system DBus service.
It allows callers to configure network authentication and domain membership
@@ -1633,9 +1609,7 @@ realms/domains like Active Directory or IPA.")
(find-files "." ".*")))
#t))))))
(native-inputs
- `(("perl-module-build" ,perl-module-build)
- ("perl-test-pod" ,perl-test-pod)
- ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (list perl-module-build perl-test-pod perl-test-pod-coverage))
(home-page "https://metacpan.org/pod/distribution/File-Rename/rename.PL")
(synopsis "Perl extension for renaming multiple files")
(description
@@ -1717,9 +1691,7 @@ at once based on a Perl regular expression.")
(add-after 'install 'install-info
(lambda _
(invoke "make" "install-info"))))))
- (native-inputs `(("texinfo" ,texinfo)
- ("automake" ,automake)
- ("util-linux" ,util-linux))) ; for 'cal'
+ (native-inputs (list texinfo automake util-linux)) ; for 'cal'
(inputs `(("coreutils*" ,coreutils)
("mailutils" ,mailutils)))
(home-page "https://www.gnu.org/software/rottlog/")
@@ -1808,7 +1780,7 @@ system administrator.")
;; the chroot's /etc/passwd doesn't have it. Turn off the tests.
#:tests? #f))
(native-inputs
- `(("groff" ,groff)))
+ (list groff))
(inputs
`(("coreutils" ,coreutils)
,@(if (hurd-target?)
@@ -1872,7 +1844,7 @@ commands and their arguments.")
(list (string-append "CC=" ,(cc-for-target)))
#:tests? #f)) ; no test suite
(native-inputs
- `(("bison" ,bison)))
+ (list bison))
(home-page "https://github.com/Duncaen/OpenDoas")
(synopsis "Portable version of OpenBSD's doas command")
(description "Doas is a minimal replacement for the venerable sudo. It was
@@ -1967,11 +1939,9 @@ features of sudo with a fraction of the codebase.")
"/lib"))
#:tests? #f))
(inputs
- `(("readline" ,readline)
- ("libnl" ,libnl)
- ("openssl" ,openssl)))
+ (list readline libnl openssl))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(home-page "https://w1.fi/wpa_supplicant/")
(synopsis "Connecting to WPA and WPA2-protected wireless networks")
(description
@@ -1992,8 +1962,8 @@ command.")
(define-public wpa-supplicant
(package (inherit wpa-supplicant-minimal)
(name "wpa-supplicant")
- (inputs `(("dbus" ,dbus)
- ,@(package-inputs wpa-supplicant-minimal)))
+ (inputs (modify-inputs (package-inputs wpa-supplicant-minimal)
+ (prepend dbus)))
(arguments
(substitute-keyword-arguments (package-arguments wpa-supplicant-minimal)
((#:phases phases)
@@ -2019,14 +1989,12 @@ command.")
(package
(inherit wpa-supplicant)
(name "wpa-supplicant-gui")
- (inputs `(("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)
- ,@(package-inputs wpa-supplicant)))
+ (inputs (modify-inputs (package-inputs wpa-supplicant)
+ (prepend qtbase-5 qtsvg)))
(native-inputs
;; For icons.
- `(("imagemagick" ,imagemagick)
- ("inkscape" ,inkscape)
- ,@(package-native-inputs wpa-supplicant)))
+ (modify-inputs (package-native-inputs wpa-supplicant)
+ (prepend imagemagick inkscape)))
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'chdir
@@ -2118,11 +2086,10 @@ command.")
(string-append "LIBDIR=" (assoc-ref %outputs "out")
"/lib"))
#:tests? #f))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs (list pkg-config))
;; There's an optional dependency on SQLite.
- (inputs `(("openssl" ,openssl)
- ("libnl" ,libnl)))
+ (inputs (list openssl libnl))
(home-page "https://w1.fi/hostapd/")
(synopsis "Daemon for Wi-Fi access points and authentication servers")
(description
@@ -2217,8 +2184,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
(base32
"06wsrl1118sl9z76p9sh53zvzv5hpm82qks896d8slx5dgnzrrll"))))
(build-system gnu-build-system)
- (native-inputs `(("flex" ,flex)
- ("bison" ,bison)))
+ (native-inputs (list flex bison))
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output)
(string-append "CC=" ,(cc-for-target))
@@ -2252,8 +2218,7 @@ development, not the kernel implementation of ACPI.")
(base32 "1l2ik5iwmb8vxa2aqdy62zfy3zfzbpq5a0pgpka2vvlw9ivpqy5p"))))
(build-system python-build-system)
(inputs
- `(("python-psutil" ,python-psutil)
- ("python-urwid" ,python-urwid)))
+ (list python-psutil python-urwid))
(home-page "https://github.com/amanusk/s-tui")
(synopsis "Interactive terminal stress test and monitoring tool")
(description
@@ -2274,8 +2239,7 @@ utilization, temperature and power.")
"09shpd85g8dvpiw0mnwykss676g0s7lbi8ab37xjinb5lfff960p"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)))
+ (list autoconf automake))
(home-page "https://packages.debian.org/sid/stress")
(synopsis "Impose load on and stress test a computer system")
(description
@@ -2305,9 +2269,7 @@ system is under heavy load.")
"116bgpbkh3c96h6vq0880rmnpb5kbnnlvvkpsrcib6928bj8lfvi"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("flex" ,flex)))
+ (list autoconf automake flex))
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'delete-configure
@@ -2497,7 +2459,7 @@ various ways that may be running with too much privilege.")
(base32
"1mlc25sd5rgj5xmzcllci47inmfdw7cp185fday6hc9rwqkqmnaw"))))
(build-system gnu-build-system)
- (inputs `(("libcap-ng" ,libcap-ng)))
+ (inputs (list libcap-ng))
(home-page "https://www.smartmontools.org/")
(synopsis "S.M.A.R.T. harddisk control and monitoring tools")
(description
@@ -2522,8 +2484,7 @@ degradation and failure.")
(base32 "1g9p50xhi2sp0hqxml4w2k0kq9jv988q2yxm347z5349dlxvap6d"))))
(build-system gnu-build-system)
(inputs
- `(("ncurses" ,ncurses)
- ("pcre2" ,pcre2)))
+ (list ncurses pcre2))
(home-page "https://github.com/adrianlopezroche/fdupes")
(synopsis "Identify duplicate files")
(description
@@ -2653,27 +2614,24 @@ sys.argv[0] = re.sub(r'\\.([^/]*)-real$', r'\\1', sys.argv[0])
;; devel/test/utils/shippable/shippable.sh.
(invoke "ansible-test" "units" "-v")))))))
(native-inputs
- `(("openssh" ,openssh)
- ("openssl" ,openssl)
- ("python-mock" ,python-mock)
- ("python-pycrypto" ,python-pycrypto)
- ("python-pytest" ,python-pytest)
- ("python-pytest-forked" ,python-pytest-forked)
- ("python-pytest-mock" ,python-pytest-mock)
- ("python-pytest-xdist" ,python-pytest-xdist)
- ("python-pytz" ,python-pytz)))
+ (list openssh
+ openssl
+ python-mock
+ python-pycrypto
+ python-pytest
+ python-pytest-forked
+ python-pytest-mock
+ python-pytest-xdist
+ python-pytz))
(inputs ;optional dependencies captured in wrap scripts
- `(("libselinux" ,libselinux)
- ("python-paramiko" ,python-paramiko)
- ("python-passlib" ,python-passlib)
- ("python-pexpect" ,python-pexpect)
- ("sshpass" ,sshpass)))
+ (list libselinux python-paramiko python-passlib python-pexpect
+ sshpass))
(propagated-inputs ;core dependencies listed in egg-info/requires.txt
- `(("python-cryptography" ,python-cryptography)
- ("python-jinja2" ,python-jinja2)
- ("python-pyyaml" ,python-pyyaml)
- ("python-packaging" ,python-packaging) ;for version number parsing
- ("python-resolvelib" ,python-resolvelib-0.5)))
+ (list python-cryptography
+ python-jinja2
+ python-pyyaml
+ python-packaging ;for version number parsing
+ python-resolvelib-0.5))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")
(description "Ansible aims to be a radically simple IT automation system.
@@ -2709,7 +2667,7 @@ provides the following commands:
(base32 "0aab9id6dqfw2111r731c7y1p77dpzczynmgl4d989p3a7n54z0b"))))
(build-system python-build-system)
(propagated-inputs
- `(("ansible-core" ,ansible-core)))
+ (list ansible-core))
;; The Ansible collections are found by ansible-core via PYTHONPATH; the
;; following search path ensures that they are found even when Python is
;; not present in the profile.
@@ -2749,18 +2707,17 @@ modules and plugins that extend Ansible.")
"debops-debops-defaults-fall-back-to-less.patch"))))
(build-system python-build-system)
(native-inputs
- `(("git" ,git)))
+ (list git))
(inputs
- `(("ansible" ,ansible)
- ("encfs" ,encfs)
- ("fuse" ,fuse)
- ("util-linux" ,util-linux) ;; for umount
- ("findutils" ,findutils)
- ("gnupg" ,gnupg)
- ("which" ,which)))
+ (list ansible
+ encfs
+ fuse
+ util-linux ;; for umount
+ findutils
+ gnupg
+ which))
(propagated-inputs
- `(("python-future" ,python-future)
- ("python-distro" ,python-distro)))
+ (list python-future python-distro))
(arguments
`(#:tests? #f
#:phases
@@ -2911,8 +2868,7 @@ limits.")
(base32 "1rgpsh70manr2dydna9da4x7p8ahii7dgdgwir5fka340n1wrcws"))))
(build-system gnu-build-system)
(native-inputs ; for tests
- `(("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)))
+ (list python-mock python-pytest))
(inputs
`(("python" ,python-wrapper)))
(arguments
@@ -2985,8 +2941,7 @@ the command line.")
"15sgkdyijb7vbxpxjavh5qm5nvyii3fqcg9mzvw7fx8s6zmfwczp"))))
(build-system gnu-build-system)
(inputs
- `(("libpcap" ,libpcap)
- ("ncurses" ,ncurses)))
+ (list libpcap ncurses))
(arguments
;; Fix build failure with GCC 10
'(#:configure-flags '("CFLAGS=-O2 -g -fcommon")))
@@ -3020,8 +2975,7 @@ displays a table of current bandwidth usage by pairs of hosts.")
""))
#t))))
(inputs
- `(("openssl" ,openssl)
- ("libgcrypt" ,libgcrypt)))
+ (list openssl libgcrypt))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -3256,16 +3210,10 @@ throughput (in the same interval).")
(("settings\\.init\\(\\)") ""))
(invoke "py.test" "-v"))))))
(propagated-inputs
- `(("python-colorama" ,python-colorama)
- ("python-decorator" ,python-decorator)
- ("python-psutil" ,python-psutil)
- ("python-pyte" ,python-pyte)
- ("python-six" ,python-six)))
+ (list python-colorama python-decorator python-psutil python-pyte
+ python-six))
(native-inputs
- `(("go" ,go)
- ("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
- ("python-pytest-mock" ,python-pytest-mock)))
+ (list go python-mock python-pytest python-pytest-mock))
(home-page "https://github.com/nvbn/thefuck")
(synopsis "Correct mistyped console command")
(description
@@ -3330,7 +3278,7 @@ produce uniform output across heterogeneous networks.")
("gettext" ,gettext-minimal)
("libnotify" ,libnotify)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(synopsis "Lightweight battery icon for the system tray")
(description "cbatticon is a lightweight battery icon that displays
the status of your battery in the system tray.")
@@ -3361,9 +3309,9 @@ the status of your battery in the system tray.")
#:make-flags (list (string-append "PREFIX="
(assoc-ref %outputs "out")))))
(inputs
- `(("libx11" ,libx11)))
+ (list libx11))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(synopsis "Scriptable launcher menu")
(description "Interrobang is a scriptable launcher menu with a customizable
shortcut syntax and completion options.")
@@ -3400,11 +3348,9 @@ shortcut syntax and completion options.")
(("pam-util/vector\n") ""))
#t)))))
(inputs
- `(("linux-pam" ,linux-pam)
- ("mit-krb5" ,mit-krb5)))
+ (list linux-pam mit-krb5))
(native-inputs
- `(("perl" ,perl)
- ("perl-test-pod" ,perl-test-pod))) ; required for tests
+ (list perl perl-test-pod)) ; required for tests
(synopsis "Kerberos PAM module")
(description
"Pam-krb5 is a Kerberos PAM module for either MIT Kerberos or Heimdal.
@@ -3481,10 +3427,9 @@ Kerberos and Heimdal and FAST is supported with recent MIT Kerberos.")
(source
(sunxi-tools-source version))
(native-inputs
- `(("sunxi-target-tools" ,sunxi-target-tools)
- ("pkg-config" ,pkg-config)))
+ (list sunxi-target-tools pkg-config))
(inputs
- `(("libusb" ,libusb)))
+ (list libusb))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests exist
@@ -3605,18 +3550,16 @@ buffers.")
(arguments
`(#:tests? #f)) ; many of the tests try to load kernel modules
(inputs
- `(("cairo" ,cairo)
- ("elfutils" ,elfutils) ; libdw
- ("eudev" ,eudev)
- ("kmod" ,kmod)
- ("libdrm" ,libdrm)
- ("libpciaccess" ,libpciaccess)
- ("libunwind" ,libunwind)
- ("procps" ,procps)))
+ (list cairo
+ elfutils ; libdw
+ eudev
+ kmod
+ libdrm
+ libpciaccess
+ libunwind
+ procps))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("pkg-config" ,pkg-config)))
+ (list bison flex pkg-config))
(home-page "https://gitlab.freedesktop.org/drm/igt-gpu-tools")
(synopsis "Tools for development and testing of the Intel DRM driver")
(description "IGT GPU Tools is a collection of tools for development and
@@ -3704,11 +3647,7 @@ you are running, what theme or icon set you are using, etc.")
(search-input-file %build-inputs
"/bin/bash"))))))))
(inputs
- `(("bash" ,bash)
- ("bc" ,bc)
- ("scrot" ,scrot)
- ("xdpyinfo" ,xdpyinfo)
- ("xprop" ,xprop)))
+ (list bash bc scrot xdpyinfo xprop))
(home-page "https://github.com/KittyKatt/screenFetch")
(synopsis "System information script")
(description "Bash screenshot information tool which can be used to
@@ -3781,7 +3720,7 @@ everyone's screenshots nowadays.")
(base32
"1md40av6i3xvvwig5jzhy4kf3s5sgxxk35r0vcyrjd8qyndk927l"))))
(build-system trivial-build-system)
- (inputs `(("bash" ,bash)))
+ (inputs (list bash))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -3817,10 +3756,9 @@ information tool.")
(base32 "0lqn7pyy8c1vy29vn8ad4x23cw67cy1d21ghns6f3w9a1h7kyjp0"))))
(build-system gnu-build-system)
(inputs
- `(("ncurses" ,ncurses)
- ("readline" ,readline)))
+ (list ncurses readline))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(arguments
`(#:tests? #f ; no tests
#:phases
@@ -3869,18 +3807,14 @@ hard-coded.")
(lambda _
(setenv "NO_CONFIGURE" "yet"))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("autoconf-archive" ,autoconf-archive)
- ("automake" ,automake)
- ("glib" ,glib "bin") ; for glib-genmarshal, etc.
- ("gtk-doc" ,gtk-doc)
- ("pkg-config" ,pkg-config)))
+ (list autoconf
+ autoconf-archive
+ automake
+ `(,glib "bin") ; for glib-genmarshal, etc.
+ gtk-doc
+ pkg-config))
(inputs
- `(("dbus-glib" ,dbus-glib)
- ("libevdev" ,libevdev)
- ("libxml2" ,libxml2)
- ("upower" ,upower)
- ("xz" ,xz)))
+ (list dbus-glib libevdev libxml2 upower xz))
(home-page "https://01.org/linux-thermal-daemon/")
(synopsis "CPU scaling for thermal management")
(description "The Linux Thermal Daemon helps monitor and control temperature
@@ -3904,7 +3838,7 @@ on systems running the Linux kernel.")
(base32 "0q0c7bsf0pbl8napry1qyg0gl4pd8wn872h4mz9b56dx4rx90vqg"))))
(build-system gnu-build-system)
(inputs
- `(("libpcap" ,libpcap)))
+ (list libpcap))
(arguments
`(#:test-target "regress"
#:make-flags
@@ -4052,7 +3986,7 @@ Python loading in HPC environments.")
("perl" ,perl)
("procps" ,procps)))
(native-inputs
- `(("gzip" ,gzip)))
+ (list gzip))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -4158,11 +4092,9 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
(base32 "1sm99423hh90kr4wdjqi9sdrrpk65j2vz2hzj65zcxfxyr6khjci"))))
(build-system meson-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("cairo" ,cairo)
- ("libpng" ,libpng)
- ("libx11" ,libx11)))
+ (list cairo libpng libx11))
(home-page "https://gitlab.com/mildlyparallel/pscircle")
(synopsis "Visualize Linux processes in a form of radial tree")
(description
@@ -4196,15 +4128,12 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
(("= find_library") "= "))
#t))))))
(inputs
- `(("eudev" ,eudev)))
+ (list eudev))
(propagated-inputs
- `(("python-six" ,python-six)))
+ (list python-six))
(native-inputs
- `(("python-docutils" ,python-docutils)
- ("python-hypothesis" ,python-hypothesis)
- ("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
- ("python-sphinx" ,python-sphinx)))
+ (list python-docutils python-hypothesis python-mock python-pytest
+ python-sphinx))
(home-page "https://pyudev.readthedocs.io/")
(synopsis "Python udev binding")
(description "This package provides @code{udev} bindings for Python.")
@@ -4225,7 +4154,7 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
(base32 "08da6apzfkfjwasn4dxrlfxqfx7arl28apdzac5nvm0fhvws0dxk"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)))
+ (list perl))
(arguments
`(#:tests? #f ; no tests
#:make-flags
@@ -4263,15 +4192,14 @@ cache of unix and unix-like systems.")
(lambda _
(setenv "PYTHONPATH" "lib"))))))
(propagated-inputs
- `(("python-pygobject" ,python-pygobject)
- ("python-pyudev" ,python-pyudev)
-
- ;; For GUI.
- ("python-pyyaml" ,python-pyyaml)
- ("python-psutil" ,python-psutil)
- ("python-xlib" ,python-xlib)
- ("gtk+" ,gtk+)
- ("python-pygobject" ,python-pygobject)))
+ (list python-pygobject
+ python-pyudev
+ ;; For GUI.
+ python-pyyaml
+ python-psutil
+ python-xlib
+ gtk+
+ python-pygobject))
(home-page "https://pwr-solaar.github.io/Solaar/")
(synopsis "Linux devices manager for the Logitech Unifying Receiver")
(description "This package provides tools to manage clients of the
@@ -4369,7 +4297,7 @@ possible configuration issues.")
"1x2fyd7wdqlj1r76ilal06cl2wmbz0ws6i3ys204sbjh1cj6dcl7"))))
(build-system gnu-build-system)
(inputs
- `(("libpcap" ,libpcap)))
+ (list libpcap))
(arguments
`(#:tests? #f ;; No tests.
#:configure-flags (list (string-append "--with-pcap-includes="
@@ -4399,8 +4327,7 @@ tcpdump and snoop.")
(base32 "0832nh2qf9pisgwnbgx6hkylx5d7i416l19y3ly4ifv7k1p7mxqa"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)
- ("pkg-config" ,pkg-config)))
+ (list perl pkg-config))
(inputs
`(("cryptsetup" ,cryptsetup)
("libhx" ,libhx)
@@ -4463,9 +4390,7 @@ supplied by the user when logging in.")
(base32 "0rwvyyrdnw43pixp8h51rncq2inc9pbbj1j2191y5si00pjw34zr"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-pygments" ,python-pygments)
- ("python-ruamel.yaml" ,python-ruamel.yaml)
- ("python-xmltodict" ,python-xmltodict)))
+ (list python-pygments python-ruamel.yaml python-xmltodict))
(home-page "https://github.com/kellyjonbrazil/jc")
(synopsis "Convert the output of command-line tools to JSON")
(description "@code{jc} JSONifies the output of many CLI tools and
@@ -4487,7 +4412,7 @@ file-types for easier parsing in scripts.")
"19i21fqz2m40cds9pb17brjxkczqagmx2f7mfb0xdvbygaply5wz"))))
(build-system python-build-system)
(inputs
- `(("python-tabulate" ,python-tabulate)))
+ (list python-tabulate))
(home-page "https://github.com/kellyjonbrazil/jtbl")
(synopsis "Command-line tool to print JSON data as a table in the terminal")
(description "@code{jtbl} accepts piped JSON data from stdin and outputs a
@@ -4585,10 +4510,9 @@ entries, providing commands to add, remove, comment, and search.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("libnl" ,libnl)
- ("libpcap" ,libpcap)))
+ (list libnl libpcap))
(arguments
`(#:tests? #f ; None exist
#:make-flags
@@ -4747,7 +4671,7 @@ disk utilization, priority, username, state, and exit code.")
(install-file "novena-eeprom" out-bin)
(install-file "novena-eeprom.8" out-share-man)))))))
(inputs
- `(("i2c-tools" ,i2c-tools)))
+ (list i2c-tools))
(synopsis "Novena EEPROM editor")
(description "This package provides an editor for the Novena EEPROM.
Novena boards contain a device-dependent descriptive EEPROM that defines
@@ -4799,7 +4723,7 @@ the XMODEM/YMODEM/ZMODEM file transfer protocols.")
(base32 "0sdamjzvmf6cxhjmd1rjvn7zm6k10fp5n6vabyxd3yl30cgrxw2i"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)))
+ (list perl))
(arguments
`(#:make-flags (list (string-append "CC=" ,(cc-for-target))
(string-append "PREFIX=" (assoc-ref %outputs "out")))
@@ -4830,7 +4754,7 @@ setup, maintenance, supervision, or any long-running processes.")
"058x04yp6bc77hbl3qchqm7pa8f9vqfl9jryr88m8pzl7kvpif54"))))
(build-system trivial-build-system)
(inputs
- `(("lua" ,lua)))
+ (list lua))
(arguments
`(#:modules ((guix build utils))
#:builder