summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm132
1 files changed, 102 insertions, 30 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2cfa4a05e3..ba7b46401a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015, 2016 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Alex Sassmannshausen <alex.sassmannshausen@gmail.com>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
@@ -313,7 +313,7 @@ interface and is based on GNU Guile.")
(define-public cloud-utils
(package
(name "cloud-utils")
- (version "0.31")
+ (version "0.32")
(source
(origin
(method url-fetch)
@@ -322,7 +322,7 @@ interface and is based on GNU Guile.")
version "/+download/cloud-utils-" version ".tar.gz"))
(sha256
(base32
- "07fl3dlqwdzw4xx7mcxhpkks6dnmaxha80zgs9f6wmibgzni8z0r"))))
+ "0xxdi55lzw7j91zfajw7jhd2ilsqj2dy04i9brlk8j3pvb5ma8hk"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
@@ -443,7 +443,7 @@ graphs and can export its output to different formats.")
(define-public facter
(package
(name "facter")
- (version "4.0.43")
+ (version "4.0.44")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -452,7 +452,7 @@ graphs and can export its output to different formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ppzr7vsl6iw8x82c4g60mx1vz06nzwcy8byablhg0n0g6qa3pb0"))))
+ "0cs4cr5xc3yvnln9k3gdhypnq6iw4zfrhqrhslvli11l9mwdbjwn"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -2683,7 +2683,7 @@ results (ndiff), and a packet generation and response analysis tool (nping).")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/dagwieers/dstat")
+ (url "https://github.com/dstat-real/dstat")
(commit (string-append "v" version))))
(file-name (git-file-name "dstat" version))
(sha256
@@ -2875,9 +2875,13 @@ shortcut syntax and completion options.")
(version "4.8")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://archives.eyrie.org/software/kerberos/"
- "pam-krb5-" version ".tar.xz"))
+ (uri
+ (list (string-append
+ "https://archives.eyrie.org/software/kerberos/"
+ "pam-krb5-" version ".tar.xz")
+ (string-append
+ "https://archives.eyrie.org/software/ARCHIVE/"
+ "pam-krb5/pam-krb5-" version ".tar.xz")))
(patches (search-patches "pam-krb5-CVE-2020-10595.patch"))
(sha256
(base32
@@ -2911,7 +2915,7 @@ with @code{ChallengeResponseAuthentication} and @code{PrivilegeSeparation}
enabled, and supports extensive configuration either by PAM options or in
krb5.conf or both. PKINIT is supported with recent versions of both MIT
Kerberos and Heimdal and FAST is supported with recent MIT Kerberos.")
- (home-page "https://www.eyrie.org/~eagle/software/pam-krb5")
+ (home-page "https://www.eyrie.org/~eagle/software/pam-krb5/")
;; Dual licenced under a homebrew non-copyleft OR GPL (any version)
;; However, the tarball does not contain a copy of the GPL, so unless
;; we put one in, we cannot distribute it under GPL without violating
@@ -3389,40 +3393,56 @@ make it a perfect utility on modern distros.")
(define-public thermald
(package
(name "thermald")
- (version "1.9.1")
+ (version "2.3")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/01org/thermal_daemon")
+ (url "https://github.com/intel/thermal_daemon")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0iagc3jqpnh6q2fa1gx4wx6r8qg0556j60xr159zqg95djr4dv99"))))
+ (base32 "0cisaca2c2z1x9xvxc4lr6nl6yqx5bww6brh73m0p1n643jgq1dl"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(let ((out (assoc-ref %outputs "out")))
- (list (string-append "--sysconfdir="
- out "/etc")
- (string-append "--with-dbus-sys-dir="
+ (list (string-append "--with-dbus-sys-dir="
out "/etc/dbus-1/system.d")
- "--localstatedir=/var"))))
+ "--localstatedir=/var"))
+ #:make-flags
+ (list "V=1") ; log build commands
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'bootstrap 'no-early-./configure
+ (lambda _
+ (setenv "NO_CONFIGURE" "yet")
+ ;; XXX thd_trip_point.h redefines "__STDC_LIMIT_MACROS" after
+ ;; <xz>/include/lzma.h. ./configure forcibly appends -Werror
+ ;; to CXXFLAGS, overriding any -Wno-error we'd add.
+ (substitute* "configure.ac"
+ (("-Werror") ""))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
("automake" ,automake)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
+ ("gtk-doc" ,gtk-doc)
("pkg-config" ,pkg-config)))
(inputs
`(("dbus-glib" ,dbus-glib)
- ("libxml2" ,libxml2)))
+ ("libevdev" ,libevdev)
+ ("libxml2" ,libxml2)
+ ("upower" ,upower)
+ ("xz" ,xz)))
(home-page "https://01.org/linux-thermal-daemon/")
(synopsis "CPU scaling for thermal management")
(description "The Linux Thermal Daemon helps monitor and control temperature
on systems running the Linux kernel.")
;; arm and aarch64 don't have cpuid.h.
(supported-systems '("i686-linux" "x86_64-linux"))
- (license license:gpl2+)))
+ (license license:gpl2)))
(define-public masscan
(package
@@ -3571,7 +3591,7 @@ Python loading in HPC environments.")
(let ((real-name "inxi"))
(package
(name "inxi-minimal")
- (version "3.1.07-1")
+ (version "3.1.08-1")
(source
(origin
(method git-fetch)
@@ -3580,7 +3600,7 @@ Python loading in HPC environments.")
(commit version)))
(file-name (git-file-name real-name version))
(sha256
- (base32 "0hs4m2vmfc6srscaz72r6zpkn6n7msgzlps376ks38gj1l103xfn"))))
+ (base32 "15b0fn8kv09k7kzyzix1pr1wmjw5yinzgw01v8pf9p547m4a899a"))))
(build-system trivial-build-system)
(inputs
`(("bash" ,bash-minimal)
@@ -3750,26 +3770,20 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
(define-public solaar
(package
(name "solaar")
- (version "0.9.2")
+ (version "1.0.4")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/pwr/Solaar")
+ (url "https://github.com/pwr-Solaar/Solaar")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "085mfa13dap3wqik1dqlad0d7kff4rv7j4ljh99c7l8nhczkqgwm"))))
+ "15wzxxr2m5349kkvcs3k5clg1rsmvh6by2066qm4hlgvjwmigggy"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-prefix-detection
- (lambda _
- (substitute* "setup.py"
- (("'--prefix' in sys\\.argv")
- "len([x.startswith('--prefix=') for x in sys.argv]) > 0"))
- #t))
(add-before 'build 'setenv-PATH
(lambda _
(setenv "PYTHONPATH" (string-append "lib:" (getenv "PYTHONPATH")))
@@ -4122,3 +4136,61 @@ EX6150v2, DNG3700v2, R6100, R6220, R7000, D7000, WNR3500, R6400, R6800,
R8000, R8500, WNDR3800, but is likely to be compatible with many other
Netgear devices.")
(license license:gpl3+)))
+
+(define-public atop
+ (package
+ (name "atop")
+ (version "2.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.atoptool.nl/download/atop-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0crzz4i2nabyh7d6xg7fvl65qls87nbca5ihidp3nijhrrbi14ab"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ ;; The installer requires a choice between systemd or SysV.
+ "systemdinstall"
+ (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ (string-append "BINPATH=/bin")
+ (string-append "SBINPATH=/sbin")
+ (string-append "SYSDPATH=/etc/systemd/system")
+ (string-append "PMPATHD=/etc/systemd/system-sleep")
+ (string-append "MAN1PATH=/share/man/man1")
+ (string-append "MAN5PATH=/share/man/man5")
+ (string-append "MAN8PATH=/share/man/man8")
+ ;; Or else it tries to create /var/log/atop...
+ (string-append "LOGPATH="))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No ./configure script
+ (add-before 'build 'patch-build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ ;; We don't need to chown things in the build environment.
+ (("chown.*$") "")
+ ;; We can't toggle the setuid bit in the build environment.
+ (("chmod 04711") "chmod 0711")
+ ;; Otherwise, it creates a blank configuration file as a "default".
+ (("touch.*DEFPATH)/atop") "")
+ (("chmod.*DEFPATH)/atop") ""))
+ #t)))))
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("python" ,python-wrapper) ; for `atopgpud`
+ ("zlib" ,zlib)))
+ (home-page "https://www.atoptool.nl/")
+ (synopsis "Linux performance monitoring console")
+ (description "Atop is an ASCII full-screen performance monitor for Linux
+that is capable of reporting the activity of all processes (even processes have
+finished during the monitoring interval), daily logging of system and process
+activity for long-term analysis, highlighting overloaded system resources by
+using colors, etc. At regular intervals, it shows system-level activity related
+to the CPU, memory, swap, disks (including LVM) and network layers, and for
+every process (and thread) it shows e.g. the CPU utilization, memory growth,
+disk utilization, priority, username, state, and exit code.")
+ (license license:gpl2+)))