summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm49
1 files changed, 34 insertions, 15 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e80436e95c..73772166ab 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -46,6 +46,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
@@ -1772,27 +1773,18 @@ platform-specific methods.")
(define-public audit
(package
(name "audit")
- (version "2.4.5")
+ (home-page "https://people.redhat.com/sgrubb/audit/")
+ (version "2.8.4")
(source (origin
(method url-fetch)
- (uri (string-append "https://people.redhat.com/sgrubb/audit/"
- "audit-" version ".tar.gz"))
+ (uri (string-append home-page name "-" version ".tar.gz"))
(sha256
(base32
- "1q1q51dvxscbi4kbakmd4bn0xrvwwaiwvaya79925cbrqwzxsg77"))))
+ "0f4ci6ffznnmgblwgv7ich9mjfk3p6y5l6m6h3chhmzw156nj454"))))
(build-system gnu-build-system)
- (home-page "https://people.redhat.com/sgrubb/audit/")
(arguments
- `(#:configure-flags (list "--with-python=no")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- ;; In the build environmnte /etc/passwd does not contain an entry
- ;; for root/0, so we have to patch the expected value.
- (substitute* "auparse/test/auparse_test.ref"
- (("=0 \\(root\\)") "=0 (unknown(0))"))
- #t)))))
+ `(#:configure-flags (list "--with-python=no"
+ "--disable-static")))
(inputs
`(("openldap" ,openldap)
("gnutls" ,gnutls)
@@ -2740,3 +2732,30 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
;; perl-xml-dumper
;; ipmitool
,@(package-inputs inxi-minimal)))))
+
+(define-public pscircle
+ (package
+ (name "pscircle")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.com/mildlyparallel/pscircle/-/archive/v"
+ version "/pscircle-v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k757yf2bmgfrjd417l6kpcf83hlvi0z1791vz967mwcklrsb3fj"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("libpng" ,libpng)
+ ("libx11" ,libx11)))
+ (home-page "https://gitlab.com/mildlyparallel/pscircle")
+ (synopsis "Visualize Linux processes in a form of radial tree")
+ (description
+ "@code{pscircle} visualizes Linux processes in the form of a radial tree.")
+ (license license:gpl2+)))