summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm43
1 files changed, 36 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f78b411559..b24d5601cf 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -1421,7 +1421,7 @@ system administrator.")
(define-public sudo
(package
(name "sudo")
- (version "1.9.5p1")
+ (version "1.9.5p2")
(source (origin
(method url-fetch)
(uri
@@ -1431,7 +1431,7 @@ system administrator.")
version ".tar.gz")))
(sha256
(base32
- "10kqdfbfpf3vk5ihz5gwynv4pxdf1lg6ircrlanyygb549yg7pad"))
+ "0y093z4f3822rc88g9asdch12nljdamp817vjxk04mca7ks2x7jk"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1520,7 +1520,7 @@ commands and their arguments.")
(define-public opendoas
(package
(name "opendoas")
- (version "6.8")
+ (version "6.8.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1529,7 +1529,7 @@ commands and their arguments.")
(file-name (git-file-name name version))
(sha256
(base32
- "1dlwnvy8r6slxcy260gfkximp1ms510wdslpfq9y6xvd2qi5izcb"))))
+ "0gfcssm21vdfg6kcrcc7hz1h4jmhy2zv29rfqyrrj3a6r9b5ah8p"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -2103,7 +2103,7 @@ track changes in important system configuration files.")
(define-public libcap-ng
(package
(name "libcap-ng")
- (version "0.8")
+ (version "0.8.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2111,7 +2111,7 @@ track changes in important system configuration files.")
version ".tar.gz"))
(sha256
(base32
- "08cy59iassiwbmfxa5v0kb374r80290vv32f5q1mnip11av26kgi"))))
+ "1sasp1n154aqy9fz0knlb966svm7xg1zjhg1vr4q839bgjvq7h2j"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -4354,3 +4354,32 @@ This program allows you to view and manipulate this EEPROM list.")
the XMODEM/YMODEM/ZMODEM file transfer protocols.")
(home-page "https://ohse.de/uwe/software/lrzsz.html")
(license license:gpl2+)))
+
+(define-public nq
+ (package
+ (name "nq")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/leahneukirchen/nq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1db96ykz35r273jyhf7cdknqk4p2jj9l8gbz7pjy1hq4pb6ffk99"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)))
+ (arguments
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "Unix command line queue utility")
+ (description
+ "@code{nq} can create very lightweight job queue systems which require no
+setup, maintenance, supervision, or any long-running processes.")
+ (home-page "https://github.com/leahneukirchen/nq")
+ (license license:public-domain)))