summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm176
1 files changed, 131 insertions, 45 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8424f77e4a..afcf632c68 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -9,11 +9,11 @@
;;; Copyright © 2016, 2017, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Peter Feigl <peter.feigl@nexoid.at>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
@@ -56,6 +56,7 @@
#:use-module (guix build-system emacs)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
@@ -106,6 +107,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages mail)
#:use-module (gnu packages man)
#:use-module (gnu packages mcrypt)
#:use-module (gnu packages mpi)
@@ -443,7 +445,7 @@ graphs and can export its output to different formats.")
(define-public facter
(package
(name "facter")
- (version "4.0.46")
+ (version "4.0.47")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -452,7 +454,7 @@ graphs and can export its output to different formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "1pi93i1jfpmxxw22b5r4gyx5jzgrammlrjzhjr3q2bpn3kcas91j"))))
+ "1zz5kk3ad1jj8y939369dfvjh7zqwpkcqzzad7yb6wp01rc5sf88"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -514,7 +516,7 @@ or via the @code{facter} Ruby library.")
(define-public htop
(package
(name "htop")
- (version "3.0.2")
+ (version "3.0.4")
(source
(origin
(method git-fetch)
@@ -522,7 +524,7 @@ or via the @code{facter} Ruby library.")
(url "https://github.com/htop-dev/htop")
(commit version)))
(sha256
- (base32 "1qmqhbnc5yw4brd24yrp85k09770c1c00nl03mkv5pdz2bvqivk7"))
+ (base32 "1fckfv96vzqjs3lzy0cgwsqv5vh1sxca3fhvgskmnkvr5bq6cia9"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs
@@ -565,7 +567,7 @@ memory, disks, network and processes.")
(define-public pies
(package
(name "pies")
- (version "1.4")
+ (version "1.5")
(source
(origin
(method url-fetch)
@@ -573,7 +575,7 @@ memory, disks, network and processes.")
version ".tar.bz2"))
(sha256
(base32
- "14jb4pa4zs26d5j2skxbaypnwhsx2lw8jgj1irrgs03c2dnf7gp6"))))
+ "11j168qljsinaj5dwmg7nkm2z1aghi6gc3d0wf0pikflnh2q2wqf"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -948,14 +950,14 @@ recursive runs on the generated subnets. (also IPv6)
(define-public alive
(package
(name "alive")
- (version "2.0.2")
+ (version "2.0.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/alive/alive-"
version ".tar.xz"))
(sha256
(base32
- "1vrzg51ai68x9yld7vbgl58sxaw5qpx8rbakwcxn4cqq6vpxj38j"))))
+ "053hfp7s66lnilm1ii4jrjmy44wpa2cwwh6f0sl8cyz0mm813x4b"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("alive_cv_nice_ping=yes")))
(inputs `(("guile" ,guile-2.0)
@@ -1363,9 +1365,11 @@ at once based on a Perl regular expression.")
#:phases (modify-phases %standard-phases
(add-after 'unpack 'patch-paths
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "rc/rc"
- (("/usr/sbin/sendmail") "sendmail"))
+ (("/usr/sbin/sendmail")
+ (string-append (assoc-ref inputs "mailutils")
+ "/bin/mail")))
#t))
(add-after 'unpack 'fix-configure
(lambda* (#:key inputs native-inputs #:allow-other-keys)
@@ -1404,7 +1408,8 @@ at once based on a Perl regular expression.")
(native-inputs `(("texinfo" ,texinfo)
("automake" ,automake)
("util-linux" ,util-linux))) ; for 'cal'
- (inputs `(("coreutils*" ,coreutils)))
+ (inputs `(("coreutils*" ,coreutils)
+ ("mailutils" ,mailutils)))
(home-page "https://www.gnu.org/software/rottlog/")
(synopsis "Log rotation and management")
(description
@@ -1418,7 +1423,7 @@ system administrator.")
(define-public sudo
(package
(name "sudo")
- (version "1.9.3p1")
+ (version "1.9.4p2")
(source (origin
(method url-fetch)
(uri
@@ -1428,7 +1433,7 @@ system administrator.")
version ".tar.gz")))
(sha256
(base32
- "17mldsg5d08s23cskmjxfa81ibnqw3slgf3l4023j72ywi9xxffw"))
+ "0r0g8z289ipw0zpkhmm33cpfm42j01jds2q1wilhh3flg7xg2jn3"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1875,7 +1880,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
(define-public acpica
(package
(name "acpica")
- (version "20201113")
+ (version "20201217")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1883,7 +1888,7 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
version ".tar.gz"))
(sha256
(base32
- "0fmck3zklc328c8nzvfzm2xyh2i8zszzrd4k8kk8q30y4avnc6z1"))))
+ "06rdpfjmij5nni1x2wi1gnalhsza5yxq1viskjm9r11wmsjnxm2a"))))
(build-system gnu-build-system)
(native-inputs `(("flex" ,flex)
("bison" ,bison)))
@@ -2123,7 +2128,7 @@ various ways that may be running with too much privilege.")
(define-public smartmontools
(package
(name "smartmontools")
- (version "7.1")
+ (version "7.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2131,7 +2136,7 @@ various ways that may be running with too much privilege.")
version "/smartmontools-" version ".tar.gz"))
(sha256
(base32
- "0imqb7ka4ia5573w8rnpck571pjjc9698pdjcapy9cfyk4n4swrz"))))
+ "1mlc25sd5rgj5xmzcllci47inmfdw7cp185fday6hc9rwqkqmnaw"))))
(build-system gnu-build-system)
(inputs `(("libcap-ng" ,libcap-ng)))
(home-page "https://www.smartmontools.org/")
@@ -2206,13 +2211,13 @@ of supported upstream metrics systems simultaneously.")
(define-public ansible
(package
(name "ansible")
- (version "2.9.11")
+ (version "2.9.16")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "1c9ayh61qwasgncmlw7rjx5r4g5n2cpg1d5blgn53zg7xhrx1yc8"))))
+ (base32 "0j1icfqff25zm9sq6j41ipl6gcj3i67mb5bqbjf2f2q1yx6rm8sk"))))
(build-system python-build-system)
(native-inputs
`(("python-bcrypt" ,python-bcrypt)
@@ -3126,7 +3131,7 @@ buffers.")
(define-public igt-gpu-tools
(package
(name "igt-gpu-tools")
- (version "1.24")
+ (version "1.25")
(source
(origin
(method git-fetch)
@@ -3135,27 +3140,22 @@ buffers.")
(commit (string-append "igt-gpu-tools-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1gpdjs5aj6vsnzwcjvw5bb120lgffvvshi4202phr0bzw3b92ky8"))))
- (build-system gnu-build-system)
+ (base32 "1lvhkdhilw0fn4nzkpfwvrhiv8d92h811qs2v6ac3p5w7v86a9zm"))))
+ (build-system meson-build-system)
(arguments
`(#:tests? #f)) ; many of the tests try to load kernel modules
(inputs
`(("cairo" ,cairo)
("elfutils" ,elfutils) ; libdw
("eudev" ,eudev)
- ("glib" ,glib)
("kmod" ,kmod)
("libdrm" ,libdrm)
("libpciaccess" ,libpciaccess)
("libunwind" ,libunwind)
- ("libxrandr" ,libxrandr)
- ("openssl" ,openssl)
- ("procps" ,procps)
- ("util-macros" ,util-macros)))
+ ("procps" ,procps)))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
+ `(("bison" ,bison)
+ ("flex" ,flex)
("pkg-config" ,pkg-config)))
(home-page "https://gitlab.freedesktop.org/drm/igt-gpu-tools")
(synopsis "Tools for development and testing of the Intel DRM driver")
@@ -3437,7 +3437,7 @@ make it a perfect utility on modern distros.")
(define-public thermald
(package
(name "thermald")
- (version "2.3")
+ (version "2.4.1")
(source
(origin
(method git-fetch)
@@ -3446,11 +3446,11 @@ make it a perfect utility on modern distros.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0cisaca2c2z1x9xvxc4lr6nl6yqx5bww6brh73m0p1n643jgq1dl"))))
+ (base32 "0rlac7v1b59m7gh767hkd8a0r4p001nd24786fnmryygbxynd2s6"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- (let ((out (assoc-ref %outputs "out")))
+ (let ((out (assoc-ref %outputs "out")))
(list (string-append "--with-dbus-sys-dir="
out "/etc/dbus-1/system.d")
"--localstatedir=/var"))
@@ -3635,7 +3635,7 @@ Python loading in HPC environments.")
(let ((real-name "inxi"))
(package
(name "inxi-minimal")
- (version "3.1.09-1")
+ (version "3.2.01-1")
(source
(origin
(method git-fetch)
@@ -3644,7 +3644,7 @@ Python loading in HPC environments.")
(commit version)))
(file-name (git-file-name real-name version))
(sha256
- (base32 "0m6s8kxjppy3jm39is5i1lbrah29cw86rq0vamvx46izbdyf84y5"))))
+ (base32 "15bakrv3jzj5h88c3bd0cfhh6hb8b4hm79924k1ygn29sqzgyw65"))))
(build-system trivial-build-system)
(inputs
`(("bash" ,bash-minimal)
@@ -3737,6 +3737,8 @@ support forum. It runs with the @code{/exec} command in most IRC clients.")
("perl-io-socket-ssl" ,perl-io-socket-ssl)
("perl-json-xs" ,perl-json-xs)
("perl-time-hires" ,perl-time-hires)
+ ("lvm2" ,lvm2) ; lvs
+ ("mdadm" ,mdadm)
;; TODO: Add more inputs:
;; ipmi-sensors
;; hddtemp
@@ -3955,19 +3957,14 @@ tcpdump and snoop.")
(define-public pam-mount
(package
(name "pam-mount")
- (version "2.16")
+ (version "2.17")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pam-mount/pam_mount/"
- version "/pam_mount-" version ".tar.xz"))
+ "pam_mount-" version ".tar.xz"))
(sha256
- (base32
- "1rvi4irb7ylsbhvx1cr6islm2xxw1a4b19q6z4a9864ndkm0f0mf"))
- (patches
- ;; Patch adding support for encrypted volumes in LUKS2 format.
- ;; It comes from the Gentoo package definition for sys-auth/pam_mount.
- (search-patches "pam-mount-luks2-support.patch"))))
+ (base32 "1q2n6a2ah6nghdn8i6ad2wj247njwb5nx48cggxknaa6lqxylidy"))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)
@@ -4238,3 +4235,92 @@ to the CPU, memory, swap, disks (including LVM) and network layers, and for
every process (and thread) it shows e.g. the CPU utilization, memory growth,
disk utilization, priority, username, state, and exit code.")
(license license:gpl2+)))
+
+;; TODO: Unvendor u-root (pkg: forth, golang, testutil).
+(define fiano
+ (package
+ (name "fiano")
+ (version "5.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxboot/fiano.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "03ihdwwhb7g6bihx141cn0924sjs5ps6q3ps58pk1cg0g0srrr9h"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "vendor/golang.org")
+ (delete-file-recursively "vendor/github.com")
+ #t))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/linuxboot/fiano"
+ #:unpack-path "github.com/linuxboot/fiano"))
+ (native-inputs
+ `())
+ (inputs
+ `(("go-golang-org-x-text" ,go-golang-org-x-text)
+ ("go-github.com-ulikunitz-xz" ,go-github.com-ulikunitz-xz)))
+ (synopsis "UEFI image editor")
+ (description "This package provides a command-line UEFI image editor.")
+ (home-page "https://github.com/linuxboot/fiano")
+ (license license:bsd-3)))
+
+(define-public fiano-utk
+ (package
+ (inherit fiano)
+ (name "fiano-utk")
+ (arguments
+ `(#:import-path "github.com/linuxboot/fiano/cmds/utk"
+ #:unpack-path "github.com/linuxboot/fiano"))))
+
+(define-public fiano-fmap
+ (package
+ (inherit fiano)
+ (name "fiano-fmap")
+ (arguments
+ `(#:import-path "github.com/linuxboot/fiano/cmds/fmap"
+ #:unpack-path "github.com/linuxboot/fiano"))))
+
+(define-public novena-eeprom
+ (package
+ (name "novena-eeprom")
+ (version "2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xobs/novena-eeprom.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "00pd71mg0g20v0820ggp3ghf9nyj5s4wavaz9mkmrmsr91hcnf7i"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests exist
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (out-bin (string-append out "/bin"))
+ (out-share-man (string-append out "/share/man/man8")))
+ (install-file "novena-eeprom" out-bin)
+ (install-file "novena-eeprom.8" out-share-man)))))))
+ (inputs
+ `(("i2c-tools" ,i2c-tools)))
+ (synopsis "Novena EEPROM editor")
+ (description "This package provides an editor for the Novena EEPROM.
+Novena boards contain a device-dependent descriptive EEPROM that defines
+various parameters such as serial number, MAC address, and featureset.
+This program allows you to view and manipulate this EEPROM list.")
+ (home-page "https://github.com/xobs/novena-eeprom/")
+ (supported-systems '("armhf-linux"))
+ (license license:bsd-3)))