summaryrefslogtreecommitdiff
path: root/gnu/local.mk
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/local.mk')
-rw-r--r--gnu/local.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5e9dba5ab7..deece17539 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -637,8 +637,6 @@ GNU_SYSTEM_MODULES = \
%D%/system/images/hurd.scm \
\
%D%/machine.scm \
- %D%/machine/digital-ocean.scm \
- %D%/machine/ssh.scm \
\
%D%/build/accounts.scm \
%D%/build/activation.scm \
@@ -716,6 +714,14 @@ INSTALLER_MODULES = \
%D%/installer/newt/welcome.scm \
%D%/installer/newt/wifi.scm
+if HAVE_GUILE_SSH
+
+GNU_SYSTEM_MODULES += \
+ %D%/machine/digital-ocean.scm \
+ %D%/machine/ssh.scm
+
+endif HAVE_GUILE_SSH
+
# Always ship the installer modules but compile them only when
# ENABLE_INSTALLER is true.
if ENABLE_INSTALLER