summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f628fa9d0d..06b0618b43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -236,6 +236,15 @@ dnl Emacs (optional), for 'etc/indent-package.el'.
AC_PATH_PROG([EMACS], [emacs], [/usr/bin/emacs])
AC_SUBST([EMACS])
+case "$storedir" in
+ /gnu/store)
+ ;;
+ *)
+ AC_MSG_WARN([Using a store directory other than '/gnu/store' will prevent you])
+ AC_MSG_WARN([from downloading substitutes from gnu.org.])
+ ;;
+esac
+
AC_CONFIG_FILES([Makefile
po/guix/Makefile.in
po/packages/Makefile.in
@@ -245,6 +254,6 @@ AC_CONFIG_FILES([scripts/guix], [chmod +x scripts/guix])
AC_CONFIG_FILES([test-env:build-aux/test-env.in], [chmod +x test-env])
AC_CONFIG_FILES([pre-inst-env:build-aux/pre-inst-env.in],
[chmod +x pre-inst-env])
-AC_CONFIG_FILES([etc/indent-package.el], [chmod +x etc/indent-package.el])
+AC_CONFIG_FILES([etc/indent-code.el], [chmod +x etc/indent-code.el])
AC_OUTPUT