summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am69
1 files changed, 56 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index aec2bb1474..798808bde6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
-# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013 Andreas Enge <andreas@enge.fr>
# Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
# Copyright © 2016, 2018 Mathieu Lirzin <mthl@gnu.org>
@@ -103,6 +103,7 @@ MODULES = \
guix/profiles.scm \
guix/serialization.scm \
guix/nar.scm \
+ guix/narinfo.scm \
guix/derivations.scm \
guix/grafts.scm \
guix/repl.scm \
@@ -149,6 +150,7 @@ MODULES = \
guix/build-system/node.scm \
guix/build-system/perl.scm \
guix/build-system/python.scm \
+ guix/build-system/renpy.scm \
guix/build-system/ocaml.scm \
guix/build-system/qt.scm \
guix/build-system/waf.scm \
@@ -204,6 +206,7 @@ MODULES = \
guix/build/ocaml-build-system.scm \
guix/build/qt-build-system.scm \
guix/build/r-build-system.scm \
+ guix/build/renpy-build-system.scm \
guix/build/rakudo-build-system.scm \
guix/build/ruby-build-system.scm \
guix/build/scons-build-system.scm \
@@ -361,10 +364,6 @@ AUX_FILES = \
gnu/packages/aux-files/linux-libre/5.10-arm64.conf \
gnu/packages/aux-files/linux-libre/5.10-i686.conf \
gnu/packages/aux-files/linux-libre/5.10-x86_64.conf \
- gnu/packages/aux-files/linux-libre/5.9-arm.conf \
- gnu/packages/aux-files/linux-libre/5.9-arm64.conf \
- gnu/packages/aux-files/linux-libre/5.9-i686.conf \
- gnu/packages/aux-files/linux-libre/5.9-x86_64.conf \
gnu/packages/aux-files/linux-libre/5.4-arm.conf \
gnu/packages/aux-files/linux-libre/5.4-arm64.conf \
gnu/packages/aux-files/linux-libre/5.4-i686.conf \
@@ -397,6 +396,8 @@ EXAMPLES = \
GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go $(dist_noinst_DATA:%.scm=%.go)
nobase_dist_guilemodule_DATA = \
+ guix/d3.v3.js \
+ guix/graph.js \
guix/store/schema.sql \
$(MODULES) $(MODULES_NOT_COMPILED) $(AUX_FILES) $(EXAMPLES) \
$(MISC_DISTRO_FILES)
@@ -460,7 +461,6 @@ SCM_TESTS = \
tests/monads.scm \
tests/nar.scm \
tests/networking.scm \
- tests/offload.scm \
tests/opam.scm \
tests/openpgp.scm \
tests/packages.scm \
@@ -497,6 +497,12 @@ SCM_TESTS = \
tests/uuid.scm \
tests/workers.scm
+if BUILD_DAEMON_OFFLOAD
+SCM_TESTS += tests/offload.scm
+else
+EXTRA_DIST += tests/offload.scm
+endif
+
SH_TESTS = \
tests/guix-build.sh \
tests/guix-build-branch.sh \
@@ -611,8 +617,6 @@ EXTRA_DIST += \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \
build-aux/update-NEWS.scm \
- d3.v3.js \
- graph.js \
tests/test.drv \
tests/signing-key.pub \
tests/signing-key.sec \
@@ -982,9 +986,12 @@ download-po.$(1):
fi ; \
for lang in $$$$LINGUAS; do \
if wget -nv -O "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" \
- "https://translationproject.org/latest/$(1)/$$$$lang.po" ; \
+ "https://translate.fedoraproject.org/api/translations/guix/$(1)/$$$$lang/file/" ; \
then \
- mv "$(top_srcdir)/$(2)/$(3)$$$$lang.po"{.tmp,} ; \
+ msgfilter --no-wrap -i "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" \
+ cat > "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp2" ; \
+ rm "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" ; \
+ mv "$(top_srcdir)/$(2)/$(3)$$$$lang.po"{.tmp2,} ; \
else \
rm "$(top_srcdir)/$(2)/$(3)$$$$lang.po.tmp" ; \
fi ; \
@@ -994,13 +1001,49 @@ download-po.$(1):
endef
+# Checking po files for issues. This is useful to run after downloading new
+# po files.
+
+# make-check-po-rule DOMAIN DIRECTORY [FILE-NAME-PREFIX]
+define make-check-po-rule
+
+check-po.$(1):
+ if [ -f "$(top_srcdir)/$(2)/LINGUAS" ]; then \
+ LINGUAS="`grep -v '^[[:blank:]]*#' < $(top_srcdir)/$(2)/LINGUAS`" ; \
+ else \
+ LINGUAS="`(cd $(top_srcdir)/$(2); \
+ for i in *.po; do echo $$$$i; done) | cut -d . -f 2`" ; \
+ fi ; \
+ for lang in $$$$LINGUAS; do \
+ if [ -f "$(top_srcdir)/$(2)/$(3)$$$$lang.po" ]; \
+ then \
+ if ! msgfmt -c "$(top_srcdir)/$(2)/$(3)$$$$lang.po" ; \
+ then \
+ exit 1 ; \
+ fi ; \
+ fi ; \
+ done
+
+.PHONY: check-po.$(1)
+
+endef
+
+$(eval $(call make-download-po-rule,documentation-cookbook,po/doc,guix-cookbook.))
+$(eval $(call make-download-po-rule,documentation-manual,po/doc,guix-manual.))
$(eval $(call make-download-po-rule,guix,po/guix))
-$(eval $(call make-download-po-rule,guix-packages,po/packages))
-$(eval $(call make-download-po-rule,guix-manual,po/doc,guix-manual.))
+$(eval $(call make-download-po-rule,packages,po/packages))
-download-po: $(foreach domain,guix guix-packages guix-manual,download-po.$(domain))
+$(eval $(call make-check-po-rule,documentation-cookbook,po/doc,guix-cookbook.))
+$(eval $(call make-check-po-rule,documentation-manual,po/doc,guix-manual.))
+$(eval $(call make-check-po-rule,guix,po/guix))
+$(eval $(call make-check-po-rule,packages,po/packages))
+
+download-po: $(foreach domain,guix packages documentation-manual documentation-cookbook,download-po.$(domain))
.PHONY: download-po
+check-po: $(foreach domain,guix packages documentation-manual documentation-cookbook,check-po.$(domain))
+.PHONY: check-po
+
## -------------- ##
## Silent rules. ##
## -------------- ##