summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 31784adfff..49fe57a095 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,6 +80,7 @@ MODULES = \
guix/modules.scm \
guix/download.scm \
guix/discovery.scm \
+ guix/android-repo-download.scm \
guix/bzr-download.scm \
guix/git-download.scm \
guix/hg-download.scm \
@@ -109,8 +110,6 @@ MODULES = \
guix/cache.scm \
guix/cve.scm \
guix/workers.scm \
- guix/zlib.scm \
- guix/lzlib.scm \
guix/build-system.scm \
guix/build-system/android-ndk.scm \
guix/build-system/ant.scm \
@@ -172,6 +171,7 @@ MODULES = \
guix/build/minify-build-system.scm \
guix/build/font-build-system.scm \
guix/build/go-build-system.scm \
+ guix/build/android-repo.scm \
guix/build/asdf-build-system.scm \
guix/build/bzr.scm \
guix/build/copy-build-system.scm \
@@ -333,6 +333,10 @@ dist_noinst_DATA = \
AUX_FILES = \
gnu/packages/aux-files/chromium/master-preferences.json \
gnu/packages/aux-files/emacs/guix-emacs.el \
+ gnu/packages/aux-files/linux-libre/5.8-arm.conf \
+ gnu/packages/aux-files/linux-libre/5.8-arm64.conf \
+ gnu/packages/aux-files/linux-libre/5.8-i686.conf \
+ gnu/packages/aux-files/linux-libre/5.8-x86_64.conf \
gnu/packages/aux-files/linux-libre/5.4-arm.conf \
gnu/packages/aux-files/linux-libre/5.4-arm64.conf \
gnu/packages/aux-files/linux-libre/5.4-i686.conf \
@@ -423,11 +427,11 @@ SCM_TESTS = \
tests/import-utils.scm \
tests/inferior.scm \
tests/lint.scm \
- tests/lzlib.scm \
tests/modules.scm \
tests/monads.scm \
tests/nar.scm \
tests/networking.scm \
+ tests/offload.scm \
tests/opam.scm \
tests/openpgp.scm \
tests/packages.scm \
@@ -462,8 +466,7 @@ SCM_TESTS = \
tests/upstream.scm \
tests/utils.scm \
tests/uuid.scm \
- tests/workers.scm \
- tests/zlib.scm
+ tests/workers.scm
SH_TESTS = \
tests/guix-build.sh \
@@ -649,11 +652,10 @@ commit_v1_0_0 = 6298c3ffd9654d3231a6f25390b056483e8f407c
channel_intro_commit = 9edb3f66fd807b096b48283debdcddccfea34bad
channel_intro_signer = BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A 54FA
-# Authenticate the current Git checkout by checking signatures on every commit
-# starting from $(commit_v1_0_0).
-authenticate: guix/openpgp.go guix/git-authenticate.go guix/git.go
+# Authenticate the current Git checkout by checking signatures on every commit.
+authenticate:
$(AM_V_at)echo "Authenticating Git checkout..." ; \
- "$(top_builddir)/pre-inst-env" guix git authenticate \
+ guix git authenticate \
--cache-key=channels/guix --stats \
"$(channel_intro_commit)" "$(channel_intro_signer)"
@@ -834,6 +836,7 @@ release: dist-with-updated-version
image=`$(top_builddir)/pre-inst-env \
guix system disk-image \
--file-system-type=iso9660 \
+ --label="GUIX_$${system}_$(VERSION)" \
--system=$$system --fallback \
gnu/system/install.scm` ; \
if [ ! -f "$$image" ] ; then \