summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index daec24460a..d3a3dbf69a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,11 +119,16 @@ TESTS = \
tests/utils.scm \
tests/build-utils.scm \
tests/packages.scm \
- tests/union.scm
+ tests/union.scm \
+ tests/guix-build.sh
-LOG_COMPILER = \
- $(top_builddir)/pre-inst-env \
- $(GUILE) --no-auto-compile -L "$(top_srcdir)"
+TEST_EXTENSIONS = .scm .sh
+
+SCM_LOG_COMPILER = $(top_builddir)/pre-inst-env $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
+
+SH_LOG_COMPILER = $(top_builddir)/pre-inst-env $(SHELL)
+AM_SH_LOG_FLAGS = -x -e
EXTRA_DIST = \
HACKING \