summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 19 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 97f1ff514b..7474b7f375 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -319,16 +319,11 @@ dist_noinst_DATA = \
AUX_FILES = \
gnu/packages/aux-files/chromium/master-preferences.json \
gnu/packages/aux-files/emacs/guix-emacs.el \
- gnu/packages/aux-files/linux-libre/5.3-arm.conf \
- gnu/packages/aux-files/linux-libre/5.3-arm-veyron.conf \
- gnu/packages/aux-files/linux-libre/5.3-arm64.conf \
- gnu/packages/aux-files/linux-libre/5.3-i686.conf \
- gnu/packages/aux-files/linux-libre/5.3-x86_64.conf \
- gnu/packages/aux-files/linux-libre/5.2-arm.conf \
- gnu/packages/aux-files/linux-libre/5.2-arm-veyron.conf \
- gnu/packages/aux-files/linux-libre/5.2-arm64.conf \
- gnu/packages/aux-files/linux-libre/5.2-i686.conf \
- gnu/packages/aux-files/linux-libre/5.2-x86_64.conf \
+ gnu/packages/aux-files/linux-libre/5.4-arm.conf \
+ gnu/packages/aux-files/linux-libre/5.4-arm-veyron.conf \
+ gnu/packages/aux-files/linux-libre/5.4-arm64.conf \
+ gnu/packages/aux-files/linux-libre/5.4-i686.conf \
+ gnu/packages/aux-files/linux-libre/5.4-x86_64.conf \
gnu/packages/aux-files/linux-libre/4.19-arm.conf \
gnu/packages/aux-files/linux-libre/4.19-arm64.conf \
gnu/packages/aux-files/linux-libre/4.19-i686.conf \
@@ -558,6 +553,7 @@ EXTRA_DIST += \
build-aux/check-final-inputs-self-contained.scm \
build-aux/compile-as-derivation.scm \
build-aux/generate-authors.scm \
+ build-aux/git-authenticate.scm \
build-aux/test-driver.scm \
build-aux/update-guix-package.scm \
build-aux/update-NEWS.scm \
@@ -620,6 +616,18 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
install-data-hook:
touch "$(DESTDIR)$(guileobjectdir)/guix/config.go"
+# Commit corresponding to the 'v1.0.1' tag.
+commit_v1_0_1 = d68de958b60426798ed62797ff7c96c327a672ac
+
+# Authenticate the current Git checkout by checking signatures on every commit
+# starting from $(commit_v1_0_1).
+authenticate:
+ $(AM_V_at)echo "Authenticating Git checkout..." ; \
+ "$(top_builddir)/pre-inst-env" $(GUILE) \
+ --no-auto-compile -e git-authenticate \
+ "$(top_srcdir)/build-aux/git-authenticate.scm" \
+ "$(commit_v1_0_1)"
+
# Assuming Guix is already installed and the daemon is up and running, this
# rule builds from $(srcdir), creating and building derivations.
as-derivation:
@@ -870,7 +878,7 @@ cuirass-jobs.scm: $(GOBJECTS)
.PHONY: gen-ChangeLog gen-AUTHORS gen-tarball-version
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained
-.PHONY: clean-go make-go as-derivation
+.PHONY: clean-go make-go as-derivation authenticate
.PHONY: update-guix-package update-NEWS release
# Downloading up-to-date PO files.