summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/node-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index b66aab7c0c..7ce9476555 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1130,3 +1130,25 @@ This package provides the @code{Binding} class, which uses a native addon to
talk to the underlying system. You never have to use @code{Binding} objects
directly. There is also a @code{MockBinding} available (but not yet packaged
for Guix) to assist with testing.")))
+
+(define-public node-serialport-parser-regex
+ (package
+ (inherit node-serialport-binding-abstract)
+ (name "node-serialport-parser-regex")
+ (version "9.2.4")
+ (inputs `())
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/parser-regex"))))
+ #:tests? #f))
+ (synopsis "Node SerialPort parser to split data on a regular expression")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages. This package provides @code{Regex}, a parser that uses a regular
+expression to split the incoming text.")))