summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell-check.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 16353ec1d4..8443b8aa20 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -497,7 +497,7 @@ reporting and test statistics output.")
(define-public ghc-test-framework-quickcheck2
(package
(name "ghc-test-framework-quickcheck2")
- (version "0.3.0.3")
+ (version "0.3.0.4")
(source
(origin
(method url-fetch)
@@ -506,14 +506,7 @@ reporting and test statistics output.")
"test-framework-quickcheck2-" version ".tar.gz"))
(sha256
(base32
- "12p1zwrsz35r3j5gzbvixz9z1h5643rhihf5gqznmc991krwd5nc"))
- (modules '((guix build utils)))
- (snippet
- ;; The Hackage page and the cabal file linked there for this package
- ;; both list 2.9 as the upper version limit, but the source tarball
- ;; specifies 2.8. Assume the Hackage page is correct.
- '(substitute* "test-framework-quickcheck2.cabal"
- (("QuickCheck >= 2.4 && < 2.8") "QuickCheck >= 2.4 && < 2.9")))))
+ "0vj834337r6jzr3258cv68ly2sv5999mklpsrfngyk51kywsyqyp"))))
(build-system haskell-build-system)
(inputs
`(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)