summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm6
-rw-r--r--gnu/packages/patches/emacs-zones-called-interactively.patch18
2 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab861c84b6..deea3e9901 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6790,8 +6790,8 @@ customizable by the user.")
(license license:gpl2+)))
(define-public emacs-zones
- (let ((commit "353fc38a6544eb59887bee045e373406f1d038a5")
- (revision "1"))
+ (let ((commit "3169815c323966ff8e252b44e3558d6d045243fe")
+ (revision "2"))
(package
(name "emacs-zones")
(version (git-version "0" revision commit))
@@ -6804,7 +6804,7 @@ customizable by the user.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gwnw2giii2a14nlh62xp45f47cw6ikqphhzpmcw6c7mn9x5z2ar"))
+ "039msns5596rz0my7fxpanpxwg1lkhpiibm9ppnlzaajx1hszbzl"))
(patches
(search-patches
"emacs-zones-called-interactively.patch"))))
diff --git a/gnu/packages/patches/emacs-zones-called-interactively.patch b/gnu/packages/patches/emacs-zones-called-interactively.patch
index b60f390a7e..eefcfdd12e 100644
--- a/gnu/packages/patches/emacs-zones-called-interactively.patch
+++ b/gnu/packages/patches/emacs-zones-called-interactively.patch
@@ -1,4 +1,4 @@
-From fb56fbb706804215ef9af0cc575db97c373046c6 Mon Sep 17 00:00:00 2001
+From 81603e53ebaae0f0b23c4c52c7dab83e808964ec Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sun, 17 Mar 2019 01:32:04 +0100
Subject: [PATCH] This patch silences the byte-compiler.
@@ -8,36 +8,36 @@ Subject: [PATCH] This patch silences the byte-compiler.
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/zones.el b/zones.el
-index 1bf94f0..94fa9a6 100644
+index ca88d48..594ea36 100644
--- a/zones.el
+++ b/zones.el
-@@ -1031,7 +1031,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+@@ -1075,7 +1075,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
This is a destructive operation. The list structure of the variable
value can be modified."
- (zz-narrow-advice (interactive-p)))
-+ (zz-narrow-advice (called-interactively-p)))
++ (zz-narrow-advice (called-interactively-p 'interactive)))
(defadvice narrow-to-defun (after zz-add-zone--defun activate)
"Push the defun limits to the current `zz-izones-var'.
-@@ -1039,7 +1039,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+@@ -1083,7 +1083,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
This is a destructive operation. The list structure of the variable
value can be modified."
- (zz-narrow-advice (interactive-p)))
-+ (zz-narrow-advice (called-interactively-p)))
++ (zz-narrow-advice (called-interactively-p 'interactive)))
;; Call `zz-add-zone' if interactive or `zz-add-zone-anyway-p'.
;;
-@@ -1049,7 +1049,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
+@@ -1093,7 +1093,7 @@ You can use `C-x n x' to widen to a previous buffer restriction.
This is a destructive operation. The list structure of the variable
value can be modified."
- (zz-narrow-advice (interactive-p)))
-+ (zz-narrow-advice (called-interactively-p)))
++ (zz-narrow-advice (called-interactively-p 'interactive)))
;;(@* "General Commands")
--
-2.21.0
+2.22.0