summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/graphics.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3571a45b84..23f0e54b34 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -544,9 +544,18 @@ typically encountered in feature film production.")
(string-append "-DPYTHON_NUMPY_PATH="
(assoc-ref %build-inputs "python-numpy")
"/lib/python" #$python-version
- "/site-packages/")))))
+ "/site-packages/")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-bin
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (python-path (getenv "GUIX_PYTHONPATH")))
+ (wrap-program (string-append out "/bin/blender")
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path)))))))))
(inputs
- (list boost
+ (list bash-minimal
+ boost
bullet
eigen
embree