summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 851694bd4d..5e4cd85860 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -442,11 +442,18 @@ large scale eigenvalue problems.")
(inputs `(("fortran" ,gfortran)
("python" ,python-2)))
(arguments
- `(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES"
- "-DLAPACKE=ON"
-
- ;; Build the 'LAPACKE_clatms' functions.
- "-DLAPACKE_WITH_TMG=ON")
+ `(#:configure-flags (list
+ ;; Install to PREFIX/lib (the default is
+ ;; PREFIX/lib64).
+ (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out")
+ "/lib")
+
+ "-DBUILD_SHARED_LIBS:BOOL=YES"
+ "-DLAPACKE=ON"
+
+ ;; Build the 'LAPACKE_clatms' functions.
+ "-DLAPACKE_WITH_TMG=ON")
#:phases (alist-cons-before
'check 'patch-python
(lambda* (#:key inputs #:allow-other-keys)