summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/groff.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 222b4cb6dc..3a44497594 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +31,9 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system ruby)
#:use-module (gnu packages)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages bison)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages netpbm)
@@ -208,3 +211,49 @@ is usually the formatter of \"man\" documentation pages.")
"Roffit is a program that reads an nroff file and outputs an HTML file.
It is typically used to display man pages on a web site.")
(license expat))))
+
+(define-public ronn-ng
+ (package
+ (name "ronn-ng")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ronn-ng" version))
+ (sha256
+ (base32
+ "1slxfg57cabmh98fw507z4ka6lwq1pvbrqwppflxw6700pi8ykfh"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'extract-gemspec 'fix-gemspec-mustache
+ (lambda _
+ (substitute* "ronn-ng.gemspec"
+ (("(<mustache>.freeze.*~>).*(\".*$)" all start end)
+ (string-append start " 1.0" end)))
+ #t))
+ (add-after 'wrap 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref %outputs "out") "/bin/ronn")))
+ (wrap-program prog
+ `("PATH" ":" suffix ,(map
+ (lambda (exp_inpt)
+ (string-append
+ (assoc-ref %build-inputs exp_inpt)
+ "/bin"))
+ '("ruby-kramdown"
+ "ruby-mustache"
+ "ruby-nokogiri")))))
+ #t)))))
+ (inputs
+ `(("ruby-kramdown" ,ruby-kramdown)
+ ("ruby-mustache" ,ruby-mustache)
+ ("ruby-nokogiri" ,ruby-nokogiri)))
+ (synopsis
+ "Build manuals in HTML and Unix man page format from Markdown")
+ (description
+ "Ronn-NG is an updated fork of ronn. It builds manuals in HTML and Unix
+man page format from Markdown.")
+ (home-page "https://github.com/apjanke/ronn-ng")
+ (license expat)))