summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/elm.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 988cc02de1..a3863e6e6f 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -39,9 +39,9 @@
;; `elm reactor` exit with a useful error message if they aren't there.
(define %reactor-root-base
"share/elm/reactor-")
-(define-public elm-compiler
+(define-public elm
(package
- (name "elm-compiler")
+ (name "elm")
(version "0.19.1")
(source
(origin
@@ -93,7 +93,11 @@
(home-page "https://elm-lang.org")
(synopsis "Programming language for Web applications")
(description
- "This package provides Elm, a statically-typed functional programming
-language for the browser. It includes commands for developers such as
-@command{elm make} and @command{elm repl}.")
+ "Elm is a statically-typed, purely-functional programming language for
+the browser. The @command{elm} exectable includes commands for developers
+such as @command{elm make} and @command{elm repl}.")
(license license:bsd-3)))
+
+;; The 'elm' package used to be called 'elm-compiler'.
+(define-public elm-compiler
+ (deprecated-package "elm-compiler" elm))