summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cbc2d843ea..e4f2c2fa2d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6332,7 +6332,16 @@ the @code{BasicRouter}.")
(arguments
;; PyPi sources does not contain tests, recursive dependency on
;; python-sanic.
- (list #:tests? #f))
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'loosen-requirements
+ (lambda _
+ ;; Don't place an upper boundary on httpx version.
+ ;; https://github.com/sanic-org/sanic-testing/pull/39
+ (substitute* "setup.py"
+ (("httpx>=0\\.18,<0\\.23")
+ "httpx>=0.18")))))))
(propagated-inputs (list python-httpx python-sanic-bootstrap
python-websockets))
(home-page "https://github.com/sanic-org/sanic-testing/")