summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xorg.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 92ae6a824b..3f16f2c8b1 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5468,6 +5468,7 @@ draggable titlebars and borders.")
(sha256
(base32
"09k2pqmqbn2m1bpgl7jfxyqxaaxsnzbnp2bp8ycmqldqi5ln4j5g"))))
+ (replacement libx11/fixed)
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML
@@ -5495,6 +5496,21 @@ draggable titlebars and borders.")
(description "Xorg Core X11 protocol client library.")
(license license:x11)))
+(define-public libx11/fixed
+ (package
+ (inherit libx11)
+ (version "1.6.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/lib/libX11-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "1ivfzl1qwk8zh7gc0m5vb58gdxz11jwg7w3d356w16j1d5s2427i"))))))
+
;; packages of height 5 in the propagated-inputs tree
(define-public libxcursor