summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/freedesktop.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 29bb7c1664..4d06235771 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2021, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -702,6 +703,32 @@ the org.freedesktop.login1 interface over the system bus, allowing other parts
of a the system to know what users are logged in, and where.")
(license license:lgpl2.1+)))
+(define-public basu
+ (package
+ (name "basu")
+ (version "0.2.0")
+ (home-page "https://git.sr.ht/~emersion/basu")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h23n7wg18xc7xwldca18wi00iajyliixwicqyvv38qx831d8q18"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config python gperf))
+ (inputs
+ (list libcap))
+ (synopsis "The sd-bus library, extracted from systemd")
+ (description "Some projects rely on the sd-bus library for DBus support.
+However not all systems have systemd or elogind installed.
+This library provides just sd-bus (and the busctl utility).")
+ (license license:lgpl2.1+)))
+
(define-public localed
;; XXX: This package is extracted from systemd but we retain so little of it
;; that it would make more sense to maintain a fork of the bits we need.