summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/messaging.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 21928789c6..2be3b09695 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -536,6 +536,14 @@ end-to-end encryption support; XML console.")
(substitute* "configure"
(("exit 1") ""))
#t))
+ (add-after 'unpack 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ ;; prosodyctl needs to read the configuration file.
+ (("^INSTALLEDCONFIG =.*") "INSTALLEDCONFIG = /etc/prosody\n")
+ ;; prosodyctl needs a place to put auto-generated certificates.
+ (("^INSTALLEDDATA =.*") "INSTALLEDDATA = /var/lib/prosody\n"))
+ #t))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure all executables in "bin" find the required Lua