summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/freedesktop.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9cfb987976..66060eaa64 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -853,6 +853,18 @@ software.")
(base32
"05915i0bv7q62fqrs5diqwr8dz3pwqa1c1ivcgggkjyw0xk4ldp5"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'set-sysconfdir
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Work around a bug whereby the 'SYSCONFDIR' macro
+ ;; expands literally to '${prefix}/etc'.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "src/main.c"
+ (("SYSCONFDIR, \"fprintd.conf\"")
+ (string-append "\"" out "/etc\", "
+ "\"fprintd.conf\"")))
+ #t))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))