summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/backup.scm28
-rw-r--r--gnu/packages/patches/duplicity-piped-password.patch20
-rw-r--r--gnu/packages/patches/duplicity-test_selection-tmp.patch18
4 files changed, 18 insertions, 50 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3d8e462d63..0026e85a31 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -528,8 +528,6 @@ dist_patch_DATA = \
%D%/packages/patches/doc++-include-directives.patch \
%D%/packages/patches/doc++-segfault-fix.patch \
%D%/packages/patches/doxygen-test.patch \
- %D%/packages/patches/duplicity-piped-password.patch \
- %D%/packages/patches/duplicity-test_selection-tmp.patch \
%D%/packages/patches/elfutils-tests-ptrace.patch \
%D%/packages/patches/elixir-disable-failing-tests.patch \
%D%/packages/patches/einstein-build.patch \
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 8cfe470ec6..8dbe32ebdd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages dejagnu)
+ #:use-module (gnu packages ftp)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
@@ -52,7 +53,7 @@
(define-public duplicity
(package
(name "duplicity")
- (version "0.6.26")
+ (version "0.7.11")
(source
(origin
(method url-fetch)
@@ -62,18 +63,19 @@
version ".tar.gz"))
(sha256
(base32
- "0jh79syhr8n3l81jxlwsmwm1pklb4d923m2lgqbswyavh1fqmvwb"))
- (patches (search-patches "duplicity-piped-password.patch"
- "duplicity-test_selection-tmp.patch"))))
+ "01zcq9cwn4pvj68rihgjvcdgccnxvz4jrba38sbv6nqz19cs2ixh"))))
(build-system python-build-system)
(native-inputs
- `(("util-linux" ,util-linux))) ;setsid command, for the tests
+ `(("util-linux" ,util-linux) ;setsid command, for the tests
+ ("python-pexpect" ,python2-pexpect)
+ ("mock" ,python2-mock)))
+ (propagated-inputs
+ `(("lockfile" ,python2-lockfile)
+ ("urllib3" ,python2-urllib3)))
(inputs
- `(("python" ,python-2)
- ("librsync" ,librsync)
- ("mock" ,python2-mock) ;for testing
- ("lockfile" ,python2-lockfile)
- ("gnupg" ,gnupg-1) ;gpg executable needed
+ `(("librsync" ,librsync)
+ ("lftp" ,lftp)
+ ("gnupg" ,gnupg) ;gpg executable needed
("util-linux" ,util-linux) ;for setsid
("tzdata" ,tzdata)))
(arguments
@@ -81,6 +83,12 @@
#:test-target "test"
#:phases
(modify-phases %standard-phases
+ (add-before
+ 'build 'patch-source ; embed gpg store name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "duplicity/gpginterface.py"
+ (("self.call = 'gpg'")
+ (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))))
(add-before 'check 'check-setup
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "testing/functional/__init__.py"
diff --git a/gnu/packages/patches/duplicity-piped-password.patch b/gnu/packages/patches/duplicity-piped-password.patch
deleted file mode 100644
index db50f5df32..0000000000
--- a/gnu/packages/patches/duplicity-piped-password.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-This test, on three occasions, is failing with the error:
-
- EOF: End Of File (EOF) in read_nonblocking(). Braindead platform.
-
---- duplicity-0.6.24/testing/functional/test_final.py 2014-09-28 13:14:52.146001614 -0500
-+++ duplicity-0.6.24/testing/functional/test_final.py 2014-09-28 13:13:20.333546342 -0500
-@@ -156,13 +156,6 @@
- self.run_duplicity(options=["remove-older-than", "50000", "--force", self.backend_url])
- self.assertEqual(self.get_backend_files(), second_chain)
-
-- def test_piped_password(self):
-- """Make sure that prompting for a password works"""
-- self.set_environ("PASSPHRASE", None)
-- self.backup("full", "testfiles/empty_dir",
-- passphrase_input=[self.sign_passphrase, self.sign_passphrase])
-- self.restore(passphrase_input=[self.sign_passphrase])
--
-
- class OldFilenamesFinalTest(FinalTest):
-
diff --git a/gnu/packages/patches/duplicity-test_selection-tmp.patch b/gnu/packages/patches/duplicity-test_selection-tmp.patch
deleted file mode 100644
index 8f66be4dcc..0000000000
--- a/gnu/packages/patches/duplicity-test_selection-tmp.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Reported upstream at https://bugs.launchpad.net/duplicity/+bug/1375019
-
---- duplicity-0.6.24/testing/unit/test_selection.py 2014-05-09 08:27:40.000000000 -0500
-+++ duplicity-0.6.24/testing/unit/test_selection.py 2014-09-28 12:28:53.932324380 -0500
-@@ -431,10 +431,10 @@
- [(), ('1',), ('1', '1'), ('1', '2'), ('1', '3')])
-
- self.root = Path("/")
-- self.ParseTest([("--exclude", "/home/*"),
-- ("--include", "/home"),
-+ self.ParseTest([("--exclude", "/tmp/*"),
-+ ("--include", "/tmp"),
- ("--exclude", "/")],
-- [(), ("home",)])
-+ [(), ("tmp",)])
-
- if __name__ == "__main__":
- unittest.main()