summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index fffc30f913..b0b6b16ff9 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -86,7 +86,12 @@
"0l200a0v7h8bh0cwz6v7hc13ds39cgqsmfrks55b1rbj5vniyiy3"))
(patches (search-patches "guile-1.8-cpp-4.5.patch"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--disable-error-on-warning")
+ (arguments '(#:configure-flags '("--disable-error-on-warning"
+
+ ;; Build with '-O1' to work around GC
+ ;; crash on x86_64:
+ ;; <https://issues.guix.gnu.org/50427>.
+ "CFLAGS=-O1 -g -Wall")
;; Insert a phase before `configure' to patch things up.
#:phases