summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/engineering.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index d19fde7ca4..dc902ef40f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1782,7 +1782,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=27344#236>.
(package
(name "libngspice")
- (version "36")
+ (version "37")
(source
(origin
(method url-fetch)
@@ -1793,7 +1793,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
"old-releases/" version
"/ngspice-" version ".tar.gz")))
(sha256
- (base32 "133za6m9grpnnlb46sijkda7ky41mrbvfdb60i0m695sxy3q50ag"))))
+ (base32 "1gpcic6b6xk3g4956jcsqljf33kj5g43cahmydq6m8rn39sadvlv"))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.
@@ -1819,10 +1819,7 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
(list "--enable-openmp"
"--enable-ciderlib"
"--enable-xspice"
- "--with-ngshared"
- ;; Readline must be disabled to build KiCad with ngspice 34. See
- ;; https://bugs.archlinux.org/task/70563 for reference.
- "--with-readline=no")))
+ "--with-ngshared")))
(native-inputs
(list bison flex))
(inputs