summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm8
-rw-r--r--gnu/packages/crates-io.scm57
-rw-r--r--gnu/packages/emacs.scm9
-rw-r--r--gnu/packages/guile.scm4
-rw-r--r--gnu/packages/maths.scm6
-rw-r--r--gnu/packages/protobuf.scm10
-rw-r--r--gnu/packages/python-web.scm3
-rw-r--r--gnu/packages/python-xyz.scm18
-rw-r--r--gnu/packages/racket.scm4
-rw-r--r--gnu/packages/sequoia.scm3
10 files changed, 76 insertions, 46 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 63ed2175ef..7b20d863e6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -697,8 +697,8 @@ generation.")
(license license:bsd-3)))
(define-public googletest-1.8
- (package/inherit
- googletest
+ (package
+ (inherit googletest)
(version "1.8.1")
(source (origin
(method git-fetch)
@@ -1188,8 +1188,8 @@ contacting the real http server.")
;; python-bleach 3.1.0 requires this ancient version of pytest-runner.
;; Remove once no longer needed.
(define-public python-pytest-runner-2
- (package/inherit
- python-pytest-runner
+ (package
+ (inherit python-pytest-runner)
(version "2.12.2")
(source (origin
(method url-fetch)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 313c57e90f..318b2c695b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4416,7 +4416,8 @@ bindings to C and C++ libraries.")
("rust-shlex" ,rust-shlex-0.1))))))
(define-public rust-bindgen-0.49
- (package/inherit rust-bindgen-0.50
+ (package
+ (inherit rust-bindgen-0.50)
(name "rust-bindgen")
(version "0.49.4")
(source
@@ -5949,7 +5950,8 @@ little-endian.")
(("rust-serde" ,rust-serde-1))))))
(define-public rust-bytes-0.4
- (package/inherit rust-bytes-0.5
+ (package
+ (inherit rust-bytes-0.5)
(name "rust-bytes")
(version "0.4.12")
(source
@@ -7660,7 +7662,8 @@ colors.")
(license license:mpl2.0)))
(define-public rust-colored-1.9.1
- (package/inherit rust-colored-1
+ (package
+ (inherit rust-colored-1)
(name "rust-colored")
(version "1.9.1")
(source
@@ -11575,7 +11578,8 @@ Diesel.")
(license license:expat)))
(define-public rust-difference-1
- (package/inherit rust-difference-2
+ (package
+ (inherit rust-difference-2)
(name "rust-difference")
(version "1.0.0")
(source
@@ -12123,7 +12127,8 @@ from macros.")
(license (list license:expat license:unlicense))))
(define-public rust-docopt-0.8
- (package/inherit rust-docopt-1
+ (package
+ (inherit rust-docopt-1)
(name "rust-docopt")
(version "0.8.3")
(source
@@ -18312,7 +18317,8 @@ Hash-based Message Authentication Code algorithm} for SHA1.")
("rust-typed-arena" ,rust-typed-arena-1))))))
(define-public rust-html5ever-0.23
- (package/inherit rust-html5ever-0.24
+ (package
+ (inherit rust-html5ever-0.24)
(name "rust-html5ever")
(version "0.23.0")
(source
@@ -18387,7 +18393,8 @@ requests and responses.")
(license (list license:asl2.0 license:expat))))
(define-public rust-http-0.1
- (package/inherit rust-http-0.2
+ (package
+ (inherit rust-http-0.2)
(name "rust-http")
(version "0.1.17")
(source
@@ -18454,7 +18461,8 @@ HTTP request or response body.")
("rust-http" ,rust-http-0.2))))))
(define-public rust-http-body-0.1
- (package/inherit rust-http-body-0.3
+ (package
+ (inherit rust-http-body-0.3)
(name "rust-http-body")
(version "0.1.0")
(source
@@ -22410,7 +22418,8 @@ explosion.")
("rust-serde-json" ,rust-serde-json-1))))))
(define-public rust-loom-0.2
- (package/inherit rust-loom-0.3
+ (package
+ (inherit rust-loom-0.3)
(name "rust-loom")
(version "0.2.13")
(source
@@ -22432,7 +22441,8 @@ explosion.")
("rust-serde-json" ,rust-serde-json-1))))))
(define-public rust-loom-0.1
- (package/inherit rust-loom-0.3
+ (package
+ (inherit rust-loom-0.3)
(name "rust-loom")
(version "0.1.1")
(source
@@ -30534,7 +30544,8 @@ compliant email address validation.")
("rust-getopts" ,rust-getopts-0.2))))))
(define-public rust-pulldown-cmark-0.0.8
- (package/inherit rust-pulldown-cmark-0.4
+ (package
+ (inherit rust-pulldown-cmark-0.4)
(name "rust-pulldown-cmark")
(version "0.0.8")
(source
@@ -33150,7 +33161,8 @@ functionality as retain but gives mutable borrow to the predicate.")
("rust-cc" ,rust-cc-1))))))
(define-public rust-ring-0.13
- (package/inherit rust-ring-0.16
+ (package
+ (inherit rust-ring-0.16)
(name "rust-ring")
(version "0.13.5")
(source
@@ -35111,7 +35123,8 @@ rustc compiler.")
("rust-webpki" ,rust-webpki-0.18))))))
(define-public rust-rustls-0.12
- (package/inherit rust-rustls-0.16
+ (package
+ (inherit rust-rustls-0.16)
(name "rust-rustls")
(version "0.12.0")
(source
@@ -36158,7 +36171,8 @@ Pwrite traits from the scroll crate.")
("rust-untrusted" ,rust-untrusted-0.6))))))
(define-public rust-sct-0.3
- (package/inherit rust-sct-0.6
+ (package
+ (inherit rust-sct-0.6)
(name "rust-sct")
(version "0.3.0")
(source
@@ -41958,7 +41972,8 @@ template language.")
("rust-winapi" ,rust-winapi-0.2))))))
(define-public rust-term-0.2
- (package/inherit rust-term-0.4
+ (package
+ (inherit rust-term-0.4)
(name "rust-term")
(version "0.2.14")
(source
@@ -47060,7 +47075,8 @@ untrusted inputs in Rust.")
(license license:isc)))
(define-public rust-untrusted-0.6
- (package/inherit rust-untrusted-0.7
+ (package
+ (inherit rust-untrusted-0.7)
(name "rust-untrusted")
(version "0.6.2")
(source
@@ -48681,7 +48697,8 @@ Verification.")
(("rust-base64" ,rust-base64-0.9))))))
(define-public rust-webpki-0.18
- (package/inherit rust-webpki-0.21
+ (package
+ (inherit rust-webpki-0.21)
(name "rust-webpki")
(version "0.18.1")
(source
@@ -48767,7 +48784,8 @@ with webpki.")
(base32 "1d4ss607rgi9pj01zzqa13c1p3m35z314yh6lmjaj4kzvwv5gkci"))))))
(define-public rust-webpki-roots-0.17
- (package/inherit rust-webpki-roots-0.18
+ (package
+ (inherit rust-webpki-roots-0.18)
(name "rust-webpki-roots")
(version "0.17.0")
(source
@@ -48818,7 +48836,8 @@ with webpki.")
("rust-webpki" ,rust-webpki-0.18))))))
(define-public rust-webpki-roots-0.14
- (package/inherit rust-webpki-roots-0.18
+ (package
+ (inherit rust-webpki-roots-0.18)
(name "rust-webpki-roots")
(version "0.14.0")
(source
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5316d25151..1a2b98bec2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -305,7 +305,8 @@ languages.")
(define-public emacs-next
(let ((commit "2ea34662c20f71d35dd52a5ed996542c7386b9cb")
(revision "0"))
- (package/inherit emacs
+ (package
+ (inherit emacs)
(name "emacs-next")
(version (git-version "28.0.50" revision commit))
(source
@@ -326,7 +327,8 @@ languages.")
(define-public emacs-next-pgtk
(let ((commit "ae18c8ec4f0ef37c8c9cda473770ff47e41291e2")
(revision "1"))
- (package/inherit emacs-next
+ (package
+ (inherit emacs-next)
(name "emacs-next-pgtk")
(version (git-version "28.0.50" revision commit))
(source
@@ -450,7 +452,8 @@ editor (with wide ints)" )
(define-public guile-emacs
(let ((commit "41120e0f595b16387eebfbf731fff70481de1b4b")
(revision "0"))
- (package/inherit emacs
+ (package
+ (inherit emacs)
(name "guile-emacs")
(version (git-version "0.0.0" revision commit))
(source (origin
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 74c0709ea4..5de4f68093 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -269,8 +269,8 @@ without requiring the source code to be rewritten.")
(define-deprecated guile-2.2/bug-fix guile-2.2)
(define-public guile-2.2.4
- (package/inherit
- guile-2.2
+ (package
+ (inherit guile-2.2)
(version "2.2.4")
(source (origin
(inherit (package-source guile-2.2))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8cd64e7697..5062cc0347 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1230,7 +1230,8 @@ extremely large and complex data collections.")
"https://www.hdfgroup.org/ftp/HDF5/current/src/unpacked/COPYING"))))
(define-public hdf5-1.10
- (package/inherit hdf5-1.8
+ (package
+ (inherit hdf5-1.8)
(version "1.10.7")
(source
(origin
@@ -1249,7 +1250,8 @@ extremely large and complex data collections.")
(patches (search-patches "hdf5-config-date.patch"))))))
(define-public hdf5-1.12
- (package/inherit hdf5-1.8
+ (package
+ (inherit hdf5-1.8)
(version "1.12.0")
(source
(origin
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 995d543059..857adf1703 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -123,7 +123,8 @@ internal RPC protocols and file formats.")
;; Tensorflow requires version 3.6 specifically.
(define-public protobuf-3.6
- (package/inherit protobuf
+ (package
+ (inherit protobuf)
(version "3.6.1")
(source (origin
(method url-fetch)
@@ -136,8 +137,8 @@ internal RPC protocols and file formats.")
;; The 3.5 series are the last versions that do not require C++ 11.
(define-public protobuf-3.5
- (package/inherit
- protobuf
+ (package
+ (inherit protobuf)
(version "3.5.1")
(source (origin
(method url-fetch)
@@ -289,7 +290,8 @@ structured data.")
;; For tensorflow.
(define-public python-protobuf-3.6
- (package/inherit python-protobuf
+ (package
+ (inherit python-protobuf)
(name "python-protobuf")
(version (package-version protobuf-3.6) )
(source
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 72eb93541b..4468a9b8cd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -707,7 +707,8 @@ Swartz.")
(define-public python2-html2text
(let ((base (package-with-python2 python-html2text)))
- (package/inherit base
+ (package
+ (inherit base)
;; This is the last version with support for Python 2.
(version "2019.8.11")
(source (origin
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c501b65a55..5a3c6b670e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3980,7 +3980,8 @@ text styles of documentation.")
(properties `((python2-variant . ,(delay python2-pygments))))))
(define python-pygments/fixed
- (package/inherit python-pygments
+ (package
+ (inherit python-pygments)
(version "2.7.4")
(source
(origin
@@ -4969,8 +4970,8 @@ capabilities.")
(define-public python2-numpy
(let ((numpy (package-with-python2
(strip-python2-variant python-numpy))))
- (package/inherit
- numpy
+ (package
+ (inherit numpy)
(version "1.16.5")
(source (origin
(method url-fetch)
@@ -8087,7 +8088,8 @@ features useful for text console applications.")
(define-public python2-urwid
(let ((base (package-with-python2
(strip-python2-variant python-urwid))))
- (package/inherit base
+ (package
+ (inherit base)
(version "2.1.0")
(source
(origin
@@ -9528,8 +9530,8 @@ markdown_py is also provided to convert Markdown files to HTML.")
;; Markdown 3.2 dropped support for Python 2.
(define-public python2-markdown
(let ((base (package-with-python2 (strip-python2-variant python-markdown))))
- (package/inherit
- base
+ (package
+ (inherit base)
(version "3.1.1")
(source (origin
(method url-fetch)
@@ -9697,8 +9699,8 @@ from an XML-based format.")
;; Fonttools 4.x dropped support for Python 2, so stick with 3.x here.
(define-public python2-fonttools
(let ((base (package-with-python2 (strip-python2-variant python-fonttools))))
- (package/inherit
- base
+ (package
+ (inherit base)
(version "3.44.0")
(source (origin
(method url-fetch)
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 18af14b2ec..be33270b30 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -173,8 +173,8 @@ DrRacket IDE, are not included.")
(define-public racket
- (package/inherit
- racket-minimal
+ (package
+ (inherit racket-minimal)
(name "racket")
(version (package-version racket-minimal)) ; needed for origin uri to work
(source
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index cb1e2a4872..c83926ef6c 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -221,7 +221,8 @@ with OpenPGP data.")
(define-public sequoia4pEp
;; Currently pEp Engine requires sequoia in not-so-current version
- (package/inherit sequoia
+ (package
+ (inherit sequoia)
(name "sequoia")
(version "0.15.0-pEp")
(source