summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ec69f50206..a5c28afc6e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3214,6 +3214,44 @@ data.")
(supported-systems '("x86_64-linux"))
(license license:bsd-3)))
+(define-public kaiju
+ (package
+ (name "kaiju")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/bioinformatics-centre/kaiju/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0afbfalfw9y39bkwnqjrh9bghs118ws1pzj5h8l0nblgn3mbjdks"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'move-to-src-dir
+ (lambda _ (chdir "src") #t))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (mkdir-p bin)
+ (chdir "..")
+ (copy-recursively "bin" bin)
+ (copy-recursively "util" bin))
+ #t)))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "http://kaiju.binf.ku.dk/")
+ (synopsis "Fast and sensitive taxonomic classification for metagenomics")
+ (description "Kaiju is a program for sensitive taxonomic classification
+of high-throughput sequencing reads from metagenomic whole genome sequencing
+experiments.")
+ (license license:gpl3+)))
+
(define-public macs
(package
(name "macs")