summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm44
-rw-r--r--gnu/packages/browser-extensions.scm4
-rw-r--r--gnu/packages/chromium.scm8
-rw-r--r--gnu/packages/cran.scm26
-rw-r--r--gnu/packages/llvm.scm10
5 files changed, 81 insertions, 11 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 75d2b97bba..9788285707 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2188,6 +2188,50 @@ set analyses, and can deal with repeated or longitudinal data.")
biological sequences.")
(license license:gpl3)))
+(define-public r-deconvr
+ (package
+ (name "r-deconvr")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "deconvR" version))
+ (sha256
+ (base32
+ "091z3lncamscsvzj63zzbw7dr7vnkn0jwfkm5ljq4112w4rxgrm3"))))
+ (properties `((upstream-name . "deconvR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-assertthat
+ r-biocgenerics
+ r-data-table
+ r-dplyr
+ r-e1071
+ r-foreach
+ r-genomicranges
+ r-iranges
+ r-magrittr
+ r-mass
+ r-matrixstats
+ r-methylkit
+ r-nnls
+ r-quadprog
+ r-rsq
+ r-s4vectors
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/BIMSBbioinfo/deconvR")
+ (synopsis "Simulation and deconvolution of omic profiles")
+ (description
+ "This package provides a collection of functions designed for analyzing
+deconvolution of the bulk sample(s) using an atlas of reference omic signature
+profiles and a user-selected model. Users are given the option to create or
+extend a reference atlas and,also simulate the desired size of the bulk
+signature profile of the reference cell types. The package includes the
+cell-type-specific methylation atlas and, Illumina Epic B5 probe ids that can
+be used in deconvolution. Additionally, we included @code{BSmeth2Probe}, to
+make mapping WGBS data to their probe IDs easier.")
+ (license license:artistic2.0)))
+
(define-public r-decoupler
(package
(name "r-decoupler")
diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index f305552076..1012e4b643 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -51,7 +51,7 @@ supported content to the Kodi media center.")
(define ublock-origin
(package
(name "ublock-origin")
- (version "1.42.4")
+ (version "1.43.0")
(home-page "https://github.com/gorhill/uBlock")
(source (origin
(method git-fetch)
@@ -62,7 +62,7 @@ supported content to the Kodi media center.")
(file-name (git-file-name name version))
(sha256
(base32
- "1is55pxnlylcr1pfigwgfn7kcx1rapy1cafdh6g83bdhscgh75g3"))))
+ "0w0by41v1s1cbd3bfjlb7kxr2bl6r5z3jvizlx02x14hqlppma9k"))))
(build-system gnu-build-system)
(outputs '("xpi" "firefox" "chromium"))
(arguments
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 5936ab23c3..bdfebed99e 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -312,8 +312,8 @@
;; run the Blink performance tests, just remove everything to save ~70MiB.
'("third_party/blink/perf_tests"))
-(define %chromium-version "102.0.5005.61")
-(define %ungoogled-revision (string-append %chromium-version "-3"))
+(define %chromium-version "102.0.5005.115")
+(define %ungoogled-revision (string-append %chromium-version "-1"))
(define %debian-revision "debian/102.0.5005.61-1")
(define %ungoogled-origin
@@ -324,7 +324,7 @@
(file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
(sha256
(base32
- "19i4ygxjm503dmck3bdqv3fcpda3dp9wr7z306pi6i1k989rbs8l"))))
+ "1z2xkxxviggyyksga74cqa4v73gynlgzi22ckg8yv84qxrklik6p"))))
(define %debian-origin
(origin
@@ -477,7 +477,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
- "07vbi3gn9g4n04b2qi2hm34r122snrqaifa46yk3pyh1d79rfdqs"))
+ "1rj7vy824vn513hiivc90lnxvxyi2s0qkdmfqsdssv9v6zjl079h"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c1f0dc08b7..179616b43d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31617,6 +31617,32 @@ asynchronously from formatting.")
utility operations.")
(license license:gpl3)))
+(define-public r-rsq
+ (package
+ (name "r-rsq")
+ (version "2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "rsq" version))
+ (sha256
+ (base32
+ "1r628srxhhf7b51lnj4qrzgbqajkm0ls47a9rzjkvmfq4ax5i73f"))))
+ (properties `((upstream-name . "rsq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-deriv
+ r-lme4
+ r-mass
+ r-matrix
+ r-nlme))
+ (home-page "https://cran.r-project.org/package=rsq")
+ (synopsis "R-squared and related measures")
+ (description
+ "Calculate generalized R-squared, partial R-squared, and partial correlation
+coefficients for generalized linear (mixed) models (including quasi models
+with well defined variance functions).")
+ (license license:gpl2)))
+
(define-public r-webutils
(package
(name "r-webutils")
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 8bc9e8904c..c66714a097 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -541,10 +541,10 @@ output), and Binutils.")
("libc-static" ,glibc "static")))))
(define %llvm-monorepo-hashes
- '(("14.0.4" . "1y4yvx749cn3gkpc9kf48xbd2wc2lry8x5zdpk3sbrkqs8vrji4q")))
+ '(("14.0.5" . "1hdv020x4k5fp38hik3bxz8k2sr3gnyj9iym3yhjhwygzgwgxjh9")))
(define %llvm-patches
- '(("14.0.4" . ("clang-14.0-libc-search-path.patch"))))
+ '(("14.0.5" . ("clang-14.0-libc-search-path.patch"))))
(define (llvm-monorepo version)
(origin
@@ -559,7 +559,7 @@ output), and Binutils.")
(define-public llvm-14
(package
(name "llvm")
- (version "14.0.4")
+ (version "14.0.5")
(source (llvm-monorepo version))
(build-system cmake-build-system)
(outputs '("out" "opt-viewer"))
@@ -647,7 +647,7 @@ of programming tools as well as libraries with equivalent functionality.")
(package-version llvm-14)))
(sha256
(base32
- "1vcgmvh0r28a1z87p3y4h2326zi8liq7l9mcfvmx22x9bmbcpfn8"))))))
+ "1p9y5fbcw3ynb79nzyadirwdla03bq38k6d9nhv9x8z2q4ypsga4"))))))
(package
(inherit template)
(arguments
@@ -1176,7 +1176,7 @@ of programming tools as well as libraries with equivalent functionality.")
(define-public lld-14
(package
(name "lld")
- (version "14.0.4")
+ (version "14.0.5")
(source (llvm-monorepo version))
(build-system cmake-build-system)
(inputs