summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/logging.scm38
1 files changed, 23 insertions, 15 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 8c518de07d..0ab3beff15 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages tcl)
@@ -115,36 +116,43 @@ particular severity level. It allows logging to be controlled from the
command line.")
(license license:bsd-3)))
+;; This is the legacy version of the tailon package. The new version, written
+;; in Go in available here: https://github.com/gvalkov/tailon.
(define-public tailon
(package
(name "tailon")
- (version "1.3.0")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "0wl2wm6p3pc0vkk33s7rzgcfvs9cwxfmlz997pdfhlw72r00l7s5"))))
+ "0xkmrivzilsc9wqr8ms67v7399gxnh7pv5687k4rdpdgz4309fwc"))))
(build-system python-build-system)
+ (native-inputs
+ (list python-tox python-wheel))
(inputs
- (list python-pyyaml python-sockjs-tornado python-tornado-http-auth
- python-tornado))
+ (list python-pyyaml-5 python-sockjs-tornado python-tornado-http-auth
+ python-tornado python-deepmerge))
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-commands.py
- (lambda args
- (substitute* "tailon/commands.py"
- (("self\\.first_in_path\\('grep'\\)")
- (string-append"'" (which "grep") "'"))
- (("self\\.first_in_path\\('gawk', 'awk'\\)")
- (string-append"'" (which "gawk") "'"))
- (("self\\.first_in_path\\('gsed', 'sed'\\)")
- (string-append"'" (which "sed") "'"))
- (("self\\.first_in_path\\('gtail', 'tail'\\)")
- (string-append"'" (which "tail") "'")))
- #t)))))
+ (lambda args
+ (substitute* "tailon/commands.py"
+ (("self\\.first_in_path\\('grep'\\)")
+ (string-append"'" (which "grep") "'"))
+ (("self\\.first_in_path\\('gawk', 'awk'\\)")
+ (string-append"'" (which "gawk") "'"))
+ (("self\\.first_in_path\\('gsed', 'sed'\\)")
+ (string-append"'" (which "sed") "'"))
+ (("self\\.first_in_path\\('gtail', 'tail'\\)")
+ (string-append"'" (which "tail") "'")))))
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ((",<5.0.0") "")))))))
(home-page "https://tailon.readthedocs.io/")
(synopsis
"Webapp for looking at and searching through log files")