summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 26a970bb54..9839e464cf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31587,6 +31587,32 @@ zoomable and moveable map display, display of tracks and POIs from GPX files,
parallel fetching of tiles with cURL, and more.")
(license license:gpl3+)))
+(define-public emacs-corfu-terminal
+ ;; Upstream does not tag releases, version taken from package header.
+ (let ((commit "7c5a8a1c07b6c1a41b358b083d5bf7773701d26b")
+ (revision "0"))
+ (package
+ (name "emacs-corfu-terminal")
+ (version (git-version "0.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://codeberg.org/akib/emacs-corfu-terminal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pk5vfcz8w4hiqrwzwpxdjzlbhla0bw7a1h6v0mqxad0j9y7v3nw"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-corfu emacs-popon))
+ (home-page "https://codeberg.org/akib/emacs-corfu-terminal/")
+ (synopsis "Replace corfu child frames with popups")
+ (description
+ "This package replaces the child frames @code{emacs-corfu} uses
+with popups, which also work in the terminal.")
+ (license license:gpl3+))))
+
(define-public emacs-popon
;; Upstream does not tag releases. The commit below matches the version
;; bump.