summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f9ce4fdfe..a6b412e799 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3086,7 +3086,13 @@ server.")
(chdir "miniupnpc")
(setenv "CC" #$(cc-for-target))
(substitute* "Makefile"
- (("/bin/sh") (search-input-file inputs "/bin/sh"))))))))
+ (("/bin/sh") (search-input-file inputs "/bin/sh")))))
+ (add-before 'subdir 'remove-kernel-version
+ ;; Avoid embedding the running kernel version for reproducible builds
+ (lambda _
+ (substitute*
+ "miniupnpc/updateminiupnpcstrings.sh"
+ (("^OS_VERSION=`uname -r`") "OS_VERSION=Guix")))))))
(inputs (list python)) ;we are building a Python extension
(synopsis "UPnP client for Python")
(description "Miniupnpc is a client library for Python programs to set up