summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 8da13ee866..f08227b1be 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2732,12 +2732,12 @@ exec " gcc "/bin/" program
"--disable-shared"
"--enable-languages=c,c++"
- ;; boot-triplet inserts "guix" in the triplet.
- ,@(if (equal? "powerpc64le-guix-linux-gnu" (boot-triplet))
- ;; On POWER9 (little endian) glibc needs the
- ;; 128-bit long double type.
- '("--with-long-double-128")
- '())
+ ;; On POWER9 (little endian) glibc needs the 128-bit
+ ;; long double type. 32-bit PPC is affected by the
+ ;; changes applied for powerpc64le.
+ ,@(if (string-prefix? "powerpc" (boot-triplet))
+ '("--with-long-double-128")
+ '())
;; libstdc++ cannot be built at this stage
;; ("Link tests are not allowed after