summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5de6dbf4ac..e60c455cb6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8813,7 +8813,15 @@ play with up to four players simultaneously. It has network support.")
#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "ctest"))))))
+ (lambda _ (invoke "ctest")))
+ (add-after 'install 'install-icon
+ (lambda _
+ ;; Install icon for the desktop file.
+ (let* ((out (assoc-ref %outputs "out"))
+ (icons (string-append out "/share/icons/hicolor/512x512/apps")))
+ (with-directory-excursion (string-append "../hedgewars-src-" ,version)
+ (install-file "misc/hedgewars.png" icons)))
+ #t)))))
(inputs
`(("ffmpeg" ,ffmpeg)
("freeglut" ,freeglut)