summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/algebra.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index bf62144325..11aad2ac63 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -734,9 +734,10 @@ Sine Transform} (DST) and @dfn{Discrete Hartley Transform} (DHT).")
;; but maintainers say it's a known issue and it's unsupported
;; anyway, so just skip them.
'(begin
+ (substitute* "unsupported/CMakeLists.txt"
+ (("add_subdirectory\\(test.*")
+ "# Do not build the tests for unsupported features.\n"))
(substitute* "CMakeLists.txt"
- (("add_subdirectory\\(unsupported\\)")
- "# Do not build the tests for unsupported features.\n")
;; Work around
;; <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
(("\"include/eigen3\"")