summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c76ff1922..f3d7fab973 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12465,6 +12465,13 @@ Python.")
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'set-version
+ ;; for reproducible builds, otherwise python-debian
+ ;; generates a _version.py including the date
+ (lambda _
+ (copy-file "lib/debian/_version.py.in" "lib/debian/_version.py")
+ (substitute* "lib/debian/_version.py"
+ (("__CHANGELOG_VERSION__") ,version))))
(add-after 'unpack 'remove-debian-specific-tests
;; python-apt, apt and dpkg are not yet available in guix,
;; and these tests heavily depend on them.