summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/video.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c8c1790e73..e98e7ceeb8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3977,7 +3977,10 @@ post-processing of video formats like MPEG2, H.264/AVC, and VC-1.")
(outputs '("out"
"static")) ; 3.7MiB .a file
(arguments
- `(#:phases
+ `(;; Build as C++2003 to avoid C++11 "narrowing conversion" errors.
+ #:configure-flags '("CXXFLAGS=-O2 -g -std=c++03")
+
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'remove-dates
(lambda _