summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cpp.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index eb48902034..b0d4fdeb3e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1294,6 +1294,15 @@ provides a number of utilities to make coding with expected cleaner.")
`(#:configure-flags '("-Dbenchmarks=false")
#:phases
(modify-phases %standard-phases
+ ,@(if (%current-target-system)
+ `(;; boost is a test dependency. We don't run tests when
+ ;; cross-compiling. Disable all targets that depend on it.
+ (add-after 'unpack 'do-not-check-for-boost
+ (lambda _
+ (substitute* "meson.build"
+ (("unit_test_framework = [^\n]*" all)
+ "unit_test_framework = disabler()")))))
+ '())
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?