summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/machine-learning.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 85460aebfb..88ce23c410 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2538,9 +2538,14 @@ with image data, text data, and sequence data.")
"-p" "no:pep8"
;; FIXME: python-build-system lacks PARALLEL-TESTS?
"-n" (number->string (parallel-job-count))
- ;; The following test fail only in the build container;
- ;; skip it.
- "-k" "not test_selu")))))))
+ "-k"
+ (string-append
+ ;; The following test fails only in the build
+ ;; container; skip it.
+ "not test_selu "
+ ;; The following test was found flaky and removed in
+ ;; recent versions.
+ "and not test_stateful_metrics"))))))))
(propagated-inputs
`(("python-h5py" ,python-h5py)
("python-keras-applications" ,python-keras-applications)