summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/patches/mcron-install.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e44753d596..7b0613d27b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -196,6 +196,7 @@ dist_patch_DATA = \
gnu/packages/patches/m4-readlink-EINVAL.patch \
gnu/packages/patches/m4-s_isdir.patch \
gnu/packages/patches/make-impure-dirs.patch \
+ gnu/packages/patches/mcron-install.patch \
gnu/packages/patches/perl-no-sys-dirs.patch \
gnu/packages/patches/procps-make-3.82.patch \
gnu/packages/patches/readline-link-ncurses.patch \
diff --git a/gnu/packages/patches/mcron-install.patch b/gnu/packages/patches/mcron-install.patch
new file mode 100644
index 0000000000..3cd291f576
--- /dev/null
+++ b/gnu/packages/patches/mcron-install.patch
@@ -0,0 +1,22 @@
+This patch allows us to install the Vixie-compatible binaries as
+non-root without creating /var/run, etc.
+
+--- mcron-1.0.6/makefile.in 2010-06-19 20:44:17.000000000 +0200
++++ mcron-1.0.6/makefile.in 2010-07-04 16:16:25.000000000 +0200
+@@ -1004,15 +1004,11 @@ mcron.c : main.scm crontab.scm makefile.
+ @rm -f mcron.escaped.scm > /dev/null 2>&1
+
+ install-exec-hook:
+- @if [ "x@NO_VIXIE_CLOBBER@" != "xyes" -a "`id -u`" -eq "0" ]; then \
++ @if [ "x@NO_VIXIE_CLOBBER@" != "xyes" ]; then \
+ rm -f $(fpp)cron$(EXEEXT) > /dev/null 2>&1; \
+ $(INSTALL) --mode='u=rwx' mcron$(EXEEXT) $(fpp)cron$(EXEEXT); \
+ rm -f $(fpp)crontab$(EXEEXT) > /dev/null 2>&1; \
+ $(INSTALL) --mode='u=rwxs,og=rx' mcron$(EXEEXT) $(fpp)crontab$(EXEEXT); \
+- $(INSTALL) -d --mode='u=rwx' $(DESTDIR)/var/cron; \
+- $(INSTALL) -d --mode='u=rwx,og=rx' $(DESTDIR)/var/run; \
+- $(INSTALL) -d --mode='u=rwx,og=rx' $(DESTDIR)@GUILE_SITE@; \
+- $(INSTALL) -d --mode='u=rwx,og=rx' $(DESTDIR)@GUILE_SITE@/mcron; \
+ elif [ "x@NO_VIXIE_CLOBBER@" = "xyes" ]; then \
+ echo "Not installing Vixie-style programs"; \
+ else \