summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fbb0fc399b..74becc7997 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2573,7 +2573,16 @@ in the current session, Python, and the OS.")
`(("python-pytest" ,python-pytest-bootstrap)))))
(define-public python2-six
- (package-with-python2 python-six))
+ (let ((base (package-with-python2 python-six)))
+ (package
+ (inherit base)
+ ;; Reduce Python 2 closure by disabling tests and removing the native
+ ;; inputs.
+ (arguments (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'check)))))
+ (native-inputs '()))))
(define-public python-schedule
(package