summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/monitoring.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 22b02a561b..f0a25e57a6 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -622,3 +623,29 @@ future system load (i.e., capacity planning).")
;; license:gpl2 for other plugins
(license (list license:expat license:gpl2))))
+(define-public hostscope
+ (package
+ (name "hostscope")
+ (version "8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.maier-komor.de/hostscope/hostscope-V"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0jw6yij8va0f292g4xkf9lp9sxkzfgv67ajw49g3vq42q47ld7cv"))))
+ (build-system gnu-build-system)
+ (inputs `(("ncurses" ,ncurses)))
+ (arguments '(#:tests? #f)) ;; No included tests.
+ (home-page "http://www.maier-komor.de/hostscope.html")
+ (synopsis
+ "System monitoring tool for multiple hosts")
+ (description
+ "HostScope displays key system metrics of Linux hosts, such as detailed
+CPU load, speed and temperature, I/O rates of network interfaces, I/O rates of
+disks, and user process summary information. All metrics are multicast on the
+LAN, if wanted, and clients can switch between multiple hosts on the network.
+Hostscope features a bridge to Influx DB. So Grafana can be used to visualize
+the recorded data over time.")
+ (license license:gpl3+)))