summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/freedesktop.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a9e96c9928..40d41350ac 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Anders Thuné <asse.97@gmail.com>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1920,6 +1921,26 @@ encoding names are iconv-compatible.")
;; combination is GPL 2.0+.
(license license:gpl2+)))
+(define-public python-cchardet
+ (package
+ (name "python-cchardet")
+ (version "2.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cchardet" version))
+ (sha256
+ (base32
+ "1bqfz85cd51sw0bvhvdq9ikccxi2ld7g5jpni4jkq1a5clrvca64"))))
+ (build-system python-build-system)
+ (inputs
+ `(("uchardet" ,uchardet)))
+ (home-page "https://github.com/PyYoshi/cChardet")
+ (synopsis "High-performance character encoding detection for Python")
+ (description "cChardet is a character encoding detector, written in
+Python, that binds to the C library @code{uchardet} to increase performance.")
+ (license license:gpl2+)))
+
(define-public udiskie
(package
(name "udiskie")