summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac22a69d80..0ba9f5266d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8859,6 +8859,16 @@ and parameters in Python 2 source code. These refactorings can also be applied
to occurrences in strings and comments.")
(license license:gpl2)))
+(define-public python-rope
+ (package
+ (inherit python2-rope)
+ (name "python-rope")
+ (arguments `(#:python ,python-wrapper
+ ;; XXX: Only partial python3 support, results in some failing
+ ;; tests: <https://github.com/python-rope/rope/issues/247>.
+ #:tests? #f))
+ (properties `((python2-variant . ,(delay python2-rope))))))
+
(define-public python-py3status
(package
(name "python-py3status")