summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 199fcf5fb8..36171eb538 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14041,9 +14041,8 @@ Jupyter kernels such as IJulia and IRKernel.")
(assoc-ref outputs "out") "/bin"))))))))
;; Remove the python-ipython propagated input, to avoid the cycle
(propagated-inputs
- (alist-delete
- "python-ipython"
- (package-propagated-inputs python-jupyter-console)))))
+ (modify-inputs (package-propagated-inputs python-jupyter-console)
+ (delete "python-ipython")))))
(define-public python-qtconsole
(package